Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've done an ls -l inside a directory, and my files are displaying like this :

james@nevada:~/development/tools/android-sdk-linux_86/tools$ ll
total 9512
drwxr-xr-x 3 james james    4096 2010-05-07 19:48 ./
drwxr-xr-x 6 james james    4096 2010-08-21 20:43 ../
-rwxr-xr-x 1 james james  341773 2010-05-07 19:47 adb*
-rwxr-xr-x 1 james james    3636 2010-05-07 19:47 android*
-rwxr-xr-x 1 james james    2382 2010-05-07 19:47 apkbuilder*
-rwxr-xr-x 1 james james    3265 2010-05-07 19:47 ddms*
-rwxr-xr-x 1 james james   89032 2010-05-07 19:47 dmtracedump*
-rwxr-xr-x 1 james james    1940 2010-05-07 19:47 draw9patch*
-rwxr-xr-x 1 james james 6886136 2010-05-07 19:47 emulator*
-rwxr-xr-x 1 james james  478199 2010-05-07 19:47 etc1tool*
-rwxr-xr-x 1 james james    1987 2010-05-07 19:47 hierarchyviewer*
-rwxr-xr-x 1 james james   23044 2010-05-07 19:47 hprof-conv*
-rwxr-xr-x 1 james james    1939 2010-05-07 19:47 layoutopt*
drwxr-xr-x 4 james james    4096 2010-05-07 19:48 lib/
-rwxr-xr-x 1 james james   16550 2010-05-07 19:47 mksdcard*
-rw-r--r-- 1 james james  205851 2010-05-07 19:48 NOTICE.txt
-rw-r--r-- 1 james james      33 2010-05-07 19:47 source.properties
-rwxr-xr-x 1 james james 1447936 2010-05-07 19:47 sqlite3*
-rwxr-xr-x 1 james james    3044 2010-05-07 19:47 traceview*
-rwxr-xr-x 1 james james  187965 2010-05-07 19:47 zipalign*

What does that asterisk mean?

I'm also unable to run a particular file, as follows :

james@nevada:~/development/tools/android-sdk-linux_86/tools$ ./emulator 
bash: ./emulator: No such file or directory

EDIT : I'm trying to get Eclipse to use emulator, but it keeps complaining the files does not exist, yet it is here?

share|improve this question

5 Answers 5

up vote 14 down vote accepted

Ignacio Vazquez-Abrams has already explained about the *.

As for the executable-looking emulator that you can't actually execute, this can happen when the dynamic loader requested by emulator doesn't exist. You can check what kind of file emulator is with the command file emulator, and check what dynamic loader and libraries it needs with ldd emulator (any line showing “not found” is something you need to install).

Given the name of the directory and the size of the file, emulator is probably a Linux x86 binary. I suspect you have an amd64 system. If so, you need to install a runtime environment for 32-bit applications; on Ubuntu, you need the ia32-libs package (and perhaps also ia32-libs-gtk).

You could also get this error message for a script whose interpreter as indicated in the #! line doesn't exist.

share|improve this answer
    
Interesting, I'll give what you suggested a shot. Only thing that confuses me is that I had this running yesterday, and since then have only restarted... :S –  user155695 Aug 21 '10 at 21:19
    
-bash: ./badshebang: /bin/xyzzy: bad interpreter: No such file or directory –  Dennis Williamson Aug 21 '10 at 21:58

It means that the file is executable. A classifier is shown when -F is passed to ls via the command line or otherwise.

share|improve this answer

From info ls:

`-F'
`--classify'
`--indicator-style=classify'
     Append a character to each file name indicating the file type.
     Also, for regular files that are executable, append `*'.  The file
     type indicators are `/' for directories, `@' for symbolic links,
     `|' for FIFOs, `=' for sockets, `>' for doors, and nothing for
     regular files.
share|improve this answer

Ubuntu (12.04, probably other version as well) by default features with

alias ll='ls -alF'

And as others have explained, -F is responsible for the asterisk.

Edit: by the way, you are stating you're running ls -l, running ll may not be the same at all.

share|improve this answer
4  
+1 for noting this an an Ubuntu default. –  Kazark Nov 10 '12 at 1:45

As several others have mentioned, the '-F' option to 'ls' will flag executables with the asterisk. You don't have a -F in your command line, but it is likely that 'ls' has been aliased. You can check for aliases in your shell of choice (in bash, use the built-in command 'alias' to list the aliases), or escape the 'ls' command with a backslash to disable aliasing.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.