Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I connect my eSATA drive I can see it in the BIOS.
But my Windows 7 x64 seems to not detect the eSATA drive, it's not even listed in the Device Manager..

When I just connect the drive using USB 2.0 it does show it.

None of the related questions help me, I'm using a Clevo W870CU laptop.

What can I try to get my eSATA drive to show up in Windows 7 x64 too?

share|improve this question
    
Some bios have an enable/disable option in the bios for secondary drives. Posting your Make and specific model of laptop may help others help you. –  Moab Aug 23 '10 at 15:06
    
I did post that... No such option exists. –  Tom Wijsman Aug 23 '10 at 19:53

3 Answers 3

As a question - this external SATA drive - does it have a separate AC power supply? You mention it working with USB so it is obvious the drive works only when you hookup via eSATA it doesn't. Does this drive attempt to obtain both power and data off the port? They require a special powered eSATA port and your eSATA port may not be powered.

For example, the Seagate GoFlex eSATA requires such a port.

share|improve this answer
    
It uses a separate AC power supply. –  Tom Wijsman Sep 18 '10 at 8:42
    
+1 nice thinking –  Joe Taylor Oct 27 '10 at 15:49
up vote 1 down vote accepted

It is incompatible for an odd reason that's not worth troubleshooting...

I've used USB as an alternative for a while. But, it now seems Windows 8 natively supports my eSATA!

share|improve this answer

try and find "native sata" option in bios and turn it off

edit: you could also try and prepare the partitions with some live cd that supports partitioning and see what happens then... you could do it with some kind of linux flavor that comes with a preinsalled partitioning manager (ubuntu for example)...

share|improve this answer
    
I'm using a laptop, such option doesn't exist. And even if it would exist it would disable my internal drives. –  Tom Wijsman Aug 22 '10 at 14:44
    
actually it's a common problem with laptops and sata drives - try and google "native sata problem" and see what comes up –  pootzko Aug 22 '10 at 14:50
    
I'll try to look for it... A Live CD won't help either. There are partitions as I already have used the drive before on USB 2.0, but I want to use eSATA from now on for speed reasons... –  Tom Wijsman Aug 22 '10 at 14:54
    
Do you use a Linux Live CD? If the disk doesn't show up there either, the eSATA feature is most likely disabled in the BIOS or even broken... on some desktop systems the eSATA is not available anymore if you circumvent the RAID feature - but I dn't think that apllies to your laptop. –  Andreas Aug 22 '10 at 17:00
    
BIOS is set to AHCI, so that should be fine. Don't have a Linux Live CD with a GUI at the moment... But I guess I'll have to wait till my planned reinstall after the exams and hope that the issue resolves itself. –  Tom Wijsman Aug 23 '10 at 19:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.