Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

OS X 10.6

I use deepsleep widget to put Mac into hibernate without powering DRAM. However Mac always wakes up like 2 hours later unexpected.

Things I've checked:

  1. No scheduled wake up in Energy saver
  2. Wake for network access is turned on in Energy saver (guess this would be the cause. If so, can I still leave it on and keep Mac from waking up unexpected?)
  3. syslog shows

    Wake reason = ECH1 OCH1 ECH2 OCH2

    compared with the usual wake up by any keystroke on keyboard

    Wake reason = ECH1

What could cause this? How to avoid the expected wake up? Thanks.

share|improve this question
Do you have a UPS connected to your Mac's USB port? – John Siracusa Aug 22 '10 at 20:53
@John, no UPS connected. – Stan Aug 22 '10 at 21:07
Not sure but have you check other log files for activity that occurs just after wake? – user31752 Aug 23 '10 at 5:14
I turned off 'Wake for network access' and the hibernated Mac didn't get waken up for 12 hours. So seems this is the cause. – Stan Aug 23 '10 at 23:40
You probably should post this as the answer yourself and accept it, if the problem doesn't occur again. – Daniel Beck Dec 25 '10 at 18:24

So it looks like "wake for network access" is the common cause from what I see on Apple Support. The feature "Wake on Demand" could also be as fault in the way Apple describes here.

From the latter:

With Wake on Demand enabled, your Mac will occasionally wake for a brief time, without lighting the screen, in order to maintain registrations with the Bonjour Sleep Proxy. On some Macs, sounds from the optical drive, hard drive, or fans may be heard during these brief periods.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .