Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to mount a shared drive on a Windows Server 2008 machine using a Linux machine (Fedora 13).
I try mounting by

# mount //HOSTNAME/SHARENAME /mnt/FOLDER

and I get mount error(13): Permission denied.

I have tried other options like # mount -t nfs //HOSTNAME/SHARENAME /mnt/FOLDER -o username=USERNAME and the same thing with different filesystem types (ntfs, smbfs, cifs).

I have:

  • checked all firewall configurations.
  • verified security/sharing settings for the drive
  • verified registry keys under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NfsSvr\Parameters
  • verified NFS server is running

I am familiar with Windows Server 2008 but I have never configured a system from scratch on my own. The computer I'm using used to have Windows 7 for sharing folders to a Linux server. I have just switched to Server 2008 and have not been able to mount anymore.

One thing that I think is that I tried setting up an identity mapping solution; however, I do not have a domain controller setup. I am still functioning on a workgroup. I selected anonymous but still no luck.

Thank you.

share|improve this question
    
Any reason you chose NFS rather than CIFS (aka WIndows Networking) as the share method? Windows with CIFS shares to Linux systems works pretty transparently - especially with gnome or kde. – hotei Aug 23 '10 at 1:49
up vote 0 down vote accepted

After bouncing the Linux server, everything functioned as normal... Doh!

I guess the previous mounts just needed to be cycled. Although I foolishly did not try, I'm sure that simply using the umount command or removing the directories/re-creating them would have sufficed.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .