Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a LinkSys WRT54GL v1.1 which currently has stock firmware version 4.30.7. I see that version 4.30.14 is available. The router works fine now, and the release notes look uninteresting except for one line in v4.30.9: "Resolves issue with Linux kernel vulnerability".

I have remote management turned off.

I'm aware of the 3rd-party firmwares but the stock firmware works fine for me at the moment, so I don't have an interest in those.

Is the status quo fine or should I upgrade the firmware? (It's a bit of a pain since the config has to be saved and reloaded, and obviously any mucking with firmware is risky.)

share|improve this question
    
Adding as a comment since I can't back this up. There was a recent vulnerability in most routers that even if remote management is off people could remote into your router. The linux kernal vul could be that. I would say backup your current firmware, and try it. –  MrStatic Aug 23 '10 at 1:29
    
Hmm, good point. I believe 4.30.9 was a couple of years old; 4.30.14 was released 8/28/09. So depending on how "recent" this vulnerability was, that might be something different. –  Reid Aug 23 '10 at 2:24
    
That remote management vulnerability was not a router kernel vulnerability, but a DNS issue called DNS rebinding. In other words, it's your DNS server that needs fixing for that. When people talk about the risk with "mucking with firmware," they don't mean stock firmware, which is relatively low risk, because the manufacturer will take responsibility if something breaks. Do the upgrade. –  Karl Bielefeldt Aug 23 '10 at 3:32

1 Answer 1

There's the old saying, if it works, don't fix it.

Is there any reason to upgrade? Do you need some feature that has been added to newer versions? Is your current version broken in some way?

You state no reason to upgrade, apart from the "kernel vulnerability". If you care about it, then you should read up on the details of that vulnerability to determine if it really affects your specific router. if it does, decide if you feel "at risk". Only then should you consider the upgrade. Karl's comment indicates that it's not a problem at all.

Personally, I wouldn't worry about it.

share|improve this answer
    
Yes, this is my inclination. On the kernel vulnerability, all I know about it is what's listed above, and that's not much to go on. I was hoping someone could prod me in the right direction for learning more about it. –  Reid Aug 23 '10 at 13:29
    
Ah, but you asked about whether to upgrade or not, and that's what I responded on. If you ask for details about that particular vulnerability, that's another question. (Which you are welcome to post!) –  Torben Gundtofte-Bruun Aug 23 '10 at 14:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.