Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Like the title says, apparently my IE8 has stopped keeping the history of pages I've visited. I've searched SU and Google and can't find anything that seems to describe what I'm seeing. I have IE set to retain history for 999 days (the maximum allowed):

Settings

As you can see below, apart from today and last Thursday, IE appears to be oblivious to any activity more recent than three weeks ago. Clicking on either "Thursday" or "Today" reveals no recorded history, however. Very odd behavior. Finally, the history does extend back 30 weeks to when I built the computer, and there is recorded history for every week. I'd appreciate suggestions.

NB. Windows 7 Ultimate, x64 (but 32-bit IE8).

History Pane

share|improve this question
    
Does internet explorer without addons work? (run IE with the no addons option). How about just resetting ie8 settings? –  Vervious Aug 23 '10 at 3:16
    
This is why I use Chrome –  KronoS Sep 1 '10 at 5:15
    
@KronoS: Chrome + Google = Privacy Issues. That is why I use Firefox. –  thenonhacker Sep 1 '10 at 5:27
    
Too true, especially since they are trying to take over the world with verizon. –  KronoS Sep 1 '10 at 5:48
    
I regularly use Chrome because it loads so blazingly fast. I use FF only when I need FireBug (it loads so slowly, I can usually go for coffee). Unfortunately, it seems that every time I try to abandon IE, it takes no time at all for me to find a web site that won't work on any other browser. I also use Opera and Safari. But then that's all part of "Browser Wars" and not a conversation for here. –  BillP3rd Sep 1 '10 at 15:18
show 2 more comments

3 Answers

There's a couple of things that might cause this (or might manifest like this), but I can think of nothing definitive.

Firstly, I would try increasing the disk space allowed for pages to perhaps 220 MB from the current 200 and see if it then starts saving web pages. If that's the case, then you'll probably want to re-evaluate needing to store history for just under three years, or be willing to appropriate more disk space for it. I wouldn't have thought IE8 would classify 'history' as coming under 'cached webpages' though, so this might not help.

Secondly, do you run any cleanup or optimisation programs like CCleaner? I would expect these to clear the whole history rather than a recent section, though.

Thirdly, as Nano8Blazex suggests, there could be a clash with IE8 addons. Could you kindly click on "Tools" and then "Manage add-ons" and let us know what addons you have installed? The list might be surprisingly long, so thanks in advance ;)

share|improve this answer
    
1/ I've increased space from the default 200 to 1023 MB. 2/ I don't use programs like CCleaner. 3/ I've disabled all IE addons. No change. –  BillP3rd Sep 1 '10 at 15:48
add comment

In thread IE8 does not store History or Temp Internet Files it is claimed:

IE8 in windows 7 does not store temp internet files till you disable the protected mode under security ( IE - tools - internet options - Security )

So turning off protected mode is worth trying.

Another thread, Why would IE8 on Vista not keep any history when browsing in normal mode?, suggests closing IE, going to Control Panel -> Folder Options, on the View tab enable "Show hidden files" and uncheck "Hide protected operating system files", then in directory %UserProfile%\AppData\Local\Microsoft\Windows delete the hidden system folder called "History". All history is this way reinitialized to empty, so it might take some time to verify if it works correctly now.

share|improve this answer
    
Protected mode isn't related to this problem (brighthub.com/computing/windows-platform/articles/58608.aspx). Deleting everything in the History folder hadn't occurred to me (and seems a bit extreme) but I'll definitely keep it in mind as a last resort. –  BillP3rd Sep 1 '10 at 15:30
    
@BillP3rd: (1) It doesn't hurt to try turning off protected mode. Some people with IE8 history problems reported that this fixed them. (2) If you rename History, then it's not lost. –  harrymc Sep 1 '10 at 15:34
    
I tried turning off protected mode. No history but IE did warn me on every page I visited that protected mode was disabled. Of course, if I decide to try wiping history, I'd make sure I had a copy, but I appreciate the warning. :-) –  BillP3rd Sep 1 '10 at 15:52
    
@BillP3rd: IE is not supposed to warn on every page, only once. Something might be screwed up. Maybe you should use Internet Options > Advanced Tab > Reset Button. –  harrymc Sep 1 '10 at 16:21
add comment

Try an IE Reset

enter image description here

If you're not concerned with losing history and just concerned with fixing it, I'd try an IE Reset. Works pretty well at getting IE back to normal when it starts acting up.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.