Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In XP, control-click on the "up folder" icon opens the parent folder in a new Window.

After much searching, I find no way to do this in Vista. It's easy to get to the parent folder, but not in a new window.

share|improve this question
    
Yes, it's very annoying - also in W7 –  Whisk Aug 4 '09 at 7:49
    
Agreed! This is something I do at least once a day, I have such a hard time trying to figure out why they didn't think of this. Even a web browser is smart enough to open the parent in a new window or tab. –  dggoldst Aug 4 '09 at 8:36
    
It would be great if Microsoft would assign someone to look at superuser.com for things tagged windows and annoyances. I mean, if the powerusers on this site can't do something, it means that most users can't do it either. –  dggoldst Aug 5 '09 at 10:09
add comment

6 Answers

up vote 2 down vote accepted
+100

You don't need to touch the address bar or even use the mouse at all to do this.

  1. CTRL+N to open the current folder in a new window.

  2. ALT+UP ARROW to navigate to the parent folder.

share|improve this answer
add comment

A "hacky" way is to type:

Alt + F(ile), then (Ne)w, then Enter

This opens what you have currently selected in a new window.

Note: this only works if you have a folder selected!

PS: I can't confirm if w directs you to Open in New Window, if I'm wrong, please comment. Sadly I use a local version of Windows :-(

share|improve this answer
3  
Or use AutoHotKey to macro this ;-) –  Ivo Flipse Aug 4 '09 at 8:29
    
AutoHotKey is the way! –  pavsaund Aug 4 '09 at 20:44
    
Can anyone post an AutoHotKey solution? –  dggoldst Aug 17 '09 at 5:34
    
Assuming lvo's solution works: #x::Send !f sleep 1000 (You'll have to customise this for your machine, too low and it won't fire, too high and it'll be slow (you may not even need it, depending on how snappy your explorer is) send w{return} –  Phoshi Sep 2 '09 at 11:03
    
Oh dear. There's a line break before sleep, and then again before the second return, and there should also be a Return after that to end the script. –  Phoshi Sep 2 '09 at 11:04
add comment

Wish there was a simple single click way like in xp =(

share|improve this answer
add comment

This is kind of a "round-about-way" but you can go up to the parent and then open the child in a new window (through the right click menu). The end result is you have both the child (your origin) and the parent open in windows, it just swapped windows.

FYI, it is less obvious how to open the parent window without the button. In the address bar you just need to click the name of the parent folder. If the current folder is the first one listed (like if it is on the desktop) then click the arrow to the left of the name and then click the parent (or one of its siblings even).

share|improve this answer
    
Good point, Jim. I'd also love to know how to open the parent folder when you are dealing with a folder that is the first one listed. Ugh, this OS is annoying! Why didn't they check for this sort of thing? –  dggoldst Sep 2 '09 at 13:38
add comment

To open parent window use left Alt + up arrow. Then you can right-click and open it in new window. Still not 100% what you want...

share|improve this answer
add comment

An alternate method at achieving a new window that is the parent directory of the current window. By hand my method would be Ctrl+N Alt+D ..Enter but you requested a AutoHotKey script thus the kludge below.

On Alt+Q the focus moves to the address bar then to the begining to prefix with 'explorer.exe "' then shifts to the end to suffix with '.." /n'. It works even if it is ugly as I am having difficulty passing 'explorer.exe "' and '".. /n' as whole strings. but will execute as one action without delay.

!q::Send, {ALTDOWN}d{ALTUP}{HOME}{e}{x}{p}{l}{o}{r}{e}{r}{.}{e}{x}{e}{SPACE}{"}{ALTDOWN}d{ALTUP}{END}{\}{.}{.}{"}{SPACE}{/}{n}{ENTER}

other options would be an alternate file manager.

share|improve this answer
    
You don't need to enclose normal characters in {}s, only special ones. –  Phoshi Sep 2 '09 at 14:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.