Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an external Seagate hard disk. Once I plugged it into computer, I am able to get a new drive detected, e.g. E:. However, at the time I try to read E drive, it is unreadable.

I have tried the following without good outcome

  1. try at different PCs
  2. change cable
  3. using DOS prompt to change drive

Do you have better idea to overcome this or explanation of the situation?

share|improve this question

migrated from Aug 23 '10 at 4:04

This question came from our site for system and network administrators.

Is the drive formatted? If so, what filesystem is on it? Do you have data on the drive? What version of Windows are you using? – Matthew Flaschen Aug 22 '10 at 23:53
the drive was working before, NTFS format, i have data inside, using Windows, thanks for your comment Matthew, any idea? – iwan Aug 23 '10 at 0:08
try chkdsk e: yet? – Chris S Aug 23 '10 at 0:10
it gave me this error "Cannot open volume for direct access." while trying to run chkdsk – iwan Aug 23 '10 at 1:21

1 Answer 1

Have you tried mounting that drive under a Linux system? I have run into NTFS difficulties in the past where the volume would not mount under Windows, but would mount under Linux.

share|improve this answer
hmm.. that's sounds a good idea, but frankly i don't have ready linux environment on hand.. – iwan Aug 23 '10 at 1:22
Head over to, you can boot their CD in "demo" mode which is actually a fully functioning system (file system, networking, etc.). There's a few others with similar capabilities too, if you have a specific preference. – Anonymous Aug 23 '10 at 2:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.