Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Key Info: Ubuntu 64 Lucid (No memory issues, no new hardware)

Nearly every application dies with this segfault. Googling around finds dozens of posts that have this exact problem and not a single solution so hopefully you guys can give me a hand.

Example GDB of synaptic:

Starting program: /usr/sbin/synaptic
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff31a1280 in ?? () from /lib/libc.so.6
share|improve this question
    
Did u manage to resolve your problem? I ran into the same problem. – tzippy Jun 25 '13 at 7:52

If you can start aptitude/dpkg, try reinstalling (aptitude reinstall) or rolling back the libc6-i686 package.

share|improve this answer
1  
Yup, tried to no avail. That is, I successfully reinstalled with apt-get install --reinstall libc6 but it didn't do anything – Shawn Aug 23 '10 at 13:09
1  
Did you tried rolling it back to a previous version? – whitequark Aug 23 '10 at 13:47
1  
Yes, as a matter of fact, it made things quite massively worse. Rolling back libc forces an uninstall of virtually every major package in the system. Est no bueno – Shawn Aug 24 '10 at 4:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .