Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When watching video fullscreen through VLC media player, the screensaver will jump in and activate itself ontop of the video.

I've temporarily set the screensaver timeout up from 10mins to 60, but this isn't really a solution and if I watch a long film or some 3hr NHL it's not going to be enough!

Is there a proper solution to preventing the screensaver from coming on whilst VLC is actively playing videos?

My OS is WinXP 64bit.

share|improve this question
add comment

3 Answers

If you go to Tools > Settings, change the mode to display all, Under video, their should be an option to Disable Screensaver. alt text

share|improve this answer
    
I didn't notice "Show Settings > All" before, however it is already checked to disable the screensaver. –  bcmcfc Aug 23 '10 at 10:52
    
Are you using a third party screensaver? Some of them don't properly follow the power setting rules and activate when they feel like it instead of when Windows tells them to. Also, make sure that VLC Player has focus. I have a similar issue with XBMC where if it doesn't have focus, it won't (or can't) disable the screensaver. –  MBraedley Aug 23 '10 at 12:06
    
Default XP screensaver, VLC has focus. I do have a dual monitor setup though if that makes a difference to it? –  bcmcfc Aug 24 '10 at 8:48
add comment

I don't know about the Windows version for sure, but in Linux VLC there's Tools -> Preferences (toggle Show All settings) -> Video -> Disable screensaver. You might want to search for that in Windows version, too.

share|improve this answer
add comment

For easy understanding, the below instructions are shown in this video:

http://www.youtube.com/watch?v=hmyPbhwjBn0

Since this problem is related to the operating system of any computer, this solution works for any other video player which has the same problem on screensavers.

How to disable VLC player's Screensaver for good!

While playing or after played a video on VLC, the Windows screensaver will come on (activate).

The settings option within the VLC won't work to disable it. See the path:

  1. VLC -Tools - Preferences
  2. Go to left bottom column at Show settings and activate All button.
  3. Navigate down to Video section.
  4. Mark the option "Disable screensaver"

All that won't disable the screensaver because VLC is related to your Windows settings for screensaver.

Therefore, go to Desktop, right-click, and go to Screensaver options. In Windows Vista is: right-click on Desktop - Personalize - Screen Saver.

Look at "Wait" value. If it says 10 minutes, VLC will activate the screensaver after 10 minutes of idle, EVEN THOUGH your windows screensaver is deactivated. If it say 1 minute, VLC will do it after 1 minute, and so on.

To fix all this problem, is to cheat: change the value to a very high one, like 480 minutes.

Change the value activating the screen saver and deactivating it just like i did before.

From now on, VLC won't bother you at all. :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.