Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I go to this website aiag.org, it seems to download the page, but not the images. I noticed that the page uses the HTTP protocol, but the images are referenced with the HTTPS protocol. This seems weird to me. Usually you do everything you can to avoid sending images over HTTPS because you can't cache HTTPS content, but images are the number one thing you want to cache.

Here's an example image URL pulled from the page source.

At any rate, I haven't ruled out that it's a problem on my end, possibly with the firewall or something.

The error I get when I try to load that image (in Chrome) is:

Error 109 (net::ERR_ADDRESS_UNREACHABLE): Unknown error.

If I try changing the HTTPS to HTTP in the image URL, it loads fine. This problem is verified on someone else's computer in the same company.

Is this problem on my end or on the server end?

share|improve this question
    
This is almost certainly a problem on your end, because I can reach it just fine. –  Hello71 Aug 23 '10 at 14:40

4 Answers 4

up vote 1 down vote accepted

Check with your network administrator. I guarantee he's blocking port 443 somewhere, not sure why he'd want to do that outbound, but it's probably the reason.

share|improve this answer
    
It was a corporate firewall setting, though we can't explain it. It was configured to allow HTTPS on 443, but through a proxy. That was allowing pages but not individual images like this. When we changed it from a proxy to straight packet filter rules, it worked. –  Scott Whitlock Aug 23 '10 at 19:46

It sounds like your corporate firewall is probably the culprit. Try viewing the page from a computer connected outside the company (anybody have a smartphone?)

I'm able to view the page with images (and yes, the images are served over HTTPS).

share|improve this answer

I guess it´s a problem on your end. I´m able too, to view the page with images. Even the image over the example url is perfectly displayed. Have you tried it with a different browser already? If it´s not working it could be the firewall or proxy blocking https. And yes, the images are served over HTTPS. I assume it´s to provide something like klick-jacking attacks but I´m not sure about this.

share|improve this answer

It works fine in Firefox 3.6.8 & Chromium 5.0.375.125 here. Maybe a bug (or a new "feature") in the version of Google Chrome you use? Or maybe there is a buggy proxy in use in that company?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.