Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sorry for the very long question but in this case lots of details are necessary.

Problem: My crappy Thomson TG585v7 DSL modem/wifi/LAN router reboots many times daily. I think it's because the custom ISP firmware can't handle the traffic on my home network (LAN: 1 media center pc; wifi: 1 netbook, 1 desktop, 3 wifi music players, 2 smartphones).

The firmware is locked by the ISP so cannot modify or upgrade it. Instead, I want to connect a Linksys WRT54G v7.1 wifi/LAN router to the modem. The plan is to have the "stupid" modem only talk to the more competent WRT54G which will handle all the actual network stuff. I hope that the modem will cope with just one client and the Internet traffic.

Both the modem and the WRT54G can do DHCP, so I think that one of them must be disabled.

The modem is hardwired to 10.0.0.138 (on 255.255.255.0) and the WRT54G uses 192.168.1.1 by default but can be freely changed. Is it correct to disable DHCP on the WRT54G so that only the modem provides this service?

1) I guess I must change the WRT54G to e.g. 10.0.0.139 in order to bring it onto the same network, right?
I tried that, and promptly lost connection to it. Only a hard reset brought it back, but with factory defaults.

I can configure a WLAN on either the modem or the router (let's not discuss having a public WLAN on the modem, and a private WLAN on the router). I want to disable the modem's WLAN so that only the WRT54G connects to it. I tried that, but then I couldn't reach the modem (through the WRT54G) anymore.
2) How do I set up the WRT54G to provide access the modem, and to provide Internet access?

I've tried to set up a LAN&WLAN on the WRT54G and that worked fine, but without Internet access.
3) How do I set up the WRT54G to route Internet traffic to the modem?

The final touch would be
4) How to have the WRT54G provide DHCP instead of the modem?
But since the modem's IP is hardwired, I don't know how that could work. I tried using DHCP on only the WRT54G but then wasn't able to reach any network devices.

The third question is the most problematic of them all, to me, and is where I need help most badly. If I get the above 3 questions sorted out but fail on the fourth, it is still a victory.

As a final note, it would be interesting to put a custom firmware (like Tomato) on the WRT54G, but I'll be happy if I get the network up and running without any hacking.

share|improve this question
    
Are you sure only 1 of the devices can have DHCP? I'm pretty sure they can both be DHCP'ing on their respective networks. The modem will only have 1 client (router) w/ no collision on its 10.X.X.X network. The router will NAT that connection and DHCP on its LAN side (192.168.X.X). Have you tried keeping DHCP on for both? –  hyperslug Aug 24 '10 at 4:36
    
No I haven't tried using DHCP on both yet. I am trying to find the simplest possible configuration, and even that is proving to be quite a challenge (either because my hardware is crappy or because my network administration skills are crappy). –  Torben Gundtofte-Bruun Aug 24 '10 at 7:01
    
I think DHCP on both is the simplest config. That would eliminate uncertainty about which IP to use: modem assigns random 10...X IP, router connects; router assigns random 192...X IP, computer connects. –  hyperslug Aug 24 '10 at 7:36
    
Really? Gotta try that too, then. Thanks. –  Torben Gundtofte-Bruun Aug 24 '10 at 7:43
    
Update: I've been away for a few days, and been spending time fixing a broken media center, too. I still want to solve this network issue but it has to take a back seat ... Don't worry, I won't forget this! –  Torben Gundtofte-Bruun Sep 1 '10 at 8:46

5 Answers 5

It sounds like what you want to do is put the modem into transparent bridging mode, which would cause it to just act like a modem and not have any other configuration. Just by googling I found some instructions on a forum for your model of modem, though I haven't tried it myself since I don't have one. I can describe to you the general process that you need to follow, since that's how I have my modem and router set up.

When a modem is in transparent bridging mode, you enter the ISP PPPoE information on the router, and it connects directly and transparently through the modem. The modem doesn't get an IP address at all and the external IP of the router is your internet IP.

internet <---> modem <---> router WAN port | router LAN ports/wifi <---> LAN

You would need to know your PPPoE DSL login information. It may be available in the modem's web interface, or you may need to call your ISP to get it. Once the modem is put into transparent bridging mode, you will want to configure the router with that information. The modem will no longer do DHCP, have a local IP, or anything of the sort - it will essentially be gone as far as your network is concerned, and your router will be the extent of your LAN. Make sure that the modem is attached to the router via the WAN port when you do this, not one of the LAN ports, otherwise it won't work.

Good luck, hopefully that helps you out. Make sure that you have access to a different internet connection somehow in case you make any mistakes so that you can come back to get help.

share|improve this answer
    
This sounds interesting -- I never thought that another device than the one "closest to the wall socket" could provide the ISP credentials. I know those credentials so with luck I could have the WRT54G provide those rather than the modem. I haven't seen any explicit setting named anything like "bridging", but the forum post you linked to has a configuration attached that I can investigate. (Also, my modem uses PPPoA, not PPPoE which the WRT54G offers, but it's worth trying if it works anyway. A Google search indicates that many ISP's suppotr both protocols.) –  Torben Gundtofte-Bruun Aug 24 '10 at 6:55
    
Yes, usually the ISP will tell you to use PPPoA, but PPPoE almost always works fine. The reason this works is because as far as the ISP and your network see, your modem and your router are essentially one integrated device when you do this. Give it a try, hopefully it'll work! –  nhinkle Aug 24 '10 at 16:53

The usual approach to this is to do the following.

  1. Make sure both routers are using the same subnet. Since you say your Thompson integrated router & DSL modem must use the local IP address 10.0.0.139 it appears you must set up the WRT54G to use the 10.0.0.0 network with the same subnet mask 255.255.255.0 used by the Thompson router.

  2. As you already know, only one router can be set as the DHCP server. It is also important that your settings for DHCP do NOT overlap/conflict with any of the fixed/static addresses on your local LAN. So pick an IP for the WRT54G which is not in your DHCP range. (You did not mention what range of IP addresses your DHCP currently uses).

  3. Make sure you connect the two routers via an ethernet cable in one of the local LAN ports of the WRT54G. Do not use the WLAN port on the WRT54G. (This is the easiest way to avoid using NAT on the WRT54G IMO).

  4. Make sure that the default route on whichever router you decide to use for DHCP is set to the local LAN address of your router that connects to the Internet. In other words, the default route would always be 10.0.0.139 since you said this address is "fixed" for that router. The setting for the Default Route used by the systems on your network is what determines which router they will use to access the Internet.

  5. Don't forget to turn off the WLAN/radio in the Thompson router. If both routers are trying to use Wi-Fi I expect they would interfere with each other.

FWIW, this article may also be of some help. How To Convert a Wireless Router into an Access Point

I would also suggest you use the OpenDNS name servers since they are and free and in my opinion are a little more robust. They also provide some (very) basic filtering of malware sites. But that's probably something you'd only want to fiddle with after getting everything else to work.


Response To Comments

It appears that the modem sees the WRT54G because it is listed under "detected devices", but I find it very odd that it reports the device to use the IP 10.163.55.254! I have no idea where this address comes from, and there's no response if I ping it, nor if I point a browser there.

The IP 10.163.55.254 is used as the example in the article I provided a link to. It appears you followed the instructions in that article literally instead of using them as an example intended to be modified to fit the requirements of your situation.

In that article, the author points out that his LAN router's DHCP server range is 10.168.3.100 to 10.168.3.249. This is completely different from your situation. According to your comments, your DHCP range is 10.0.0.1 through 10.0.0.254. If you cannot change this by modifying the settings for the Thompson router's DHCP, then using an IP which is unlikely to ever be assigned by DHCP such as 10.0.0.250 is what I would try.

Not sure what you mean by "default route".

There are three basic configuration values for each system in an IPv4 network.

  1. A unique IP address. The IP address is used to identify the system or device on the network.
  2. The subnet mask to use. The subnet mask is used by the system or device to decide whether a destination IP address is on your local LAN or "remote" (i.e. somewhere else in the Internet).
  3. A default route. This is simply the IP address of the device to which a data packet is sent when the destination IP of the packet is not on your local LAN.

Every PC on your LAN must have these three configuration settings. And in order to successfully communicate with another device on your local LAN or on the Internet, the settings must be consistent with the settings of the other devices on your LAN.

Let's assume your laptop tries to send an IP packet to the address 10.0.0.250. The first thing done is the subnet mask in the laptops IP settings is applied to both the laptop's IP address and the destination IP.

If the subnet mask is 255.255.255.0 then the first 3 numbers of the source & destination IP addresses (i.e. 10.0.0) are compared. If they are identical, then the destination is on the local LAN and the packet is sent directly on your ethernet.

But if the source & destination IP are different, then the packet is instead sent to the IP address of the "default route" configuration setting. The device at that IP is then supposed to figure out where to send the packet next so that it eventually reaches its ultimate destination.

What is important here is that these three settings are (part of) what DHCP assigns to your laptop and other computers. If your laptop uses Windows one way you can display the values assigned to your laptop is by issuing the command ipconfig /all in a command prompt window. The value for default route should always be the address of your Thompson router since that router is the only device on your system which is connected to the Internet.

I am pretty sure you will need to always use the DHCP server on the Thompson. In order to use DHCP on the WRT54G you would also need to be able to specify the "default route" which DHCP would instruct your PCs to use. I don't think this can be done.

The DHCP in the home routers I am familiar with usually provide their own local LAN IP address as the default route. When there is only one router and it is the only way to reach the Internet this assumption works. But when you are adding a second router as an alternate Wireless Access Point, the default route still has to be the local LAN IP of the router which is connected to the Internet which would be your Thompson.

Hope this helps some.


2'nd Response To Comments

About the IP 10.163.55.254: This address was listed in my modem's device list even before I began changing anything; that's what confuses me. I am very sure that I did not enter that IP during my configuration attempts.

Well, in that case I'm totally clueless. This whole business about not being able to configure the Thompson's DHCP range and its IP address being "hardwired" to 10.0.0.138 makes no kind of sense to me. For one thing, the Thompson's IP address should also not be in the DHCP range. Sure it's unlikely that IP would ever be assigned, but still ... it's just sloppy.

Oh, well. Perhaps you'll have some luck with the suggestion in the other answer to somehow convert the Thompson to act just as a DSL modem.

Alternately I suggest contacting your service provider and asking if they can supply you with a DSL modem without an integrated router. Or if they can't do that, perhaps you can exchange the current router for a "newer" one ... or at least one with newer firmware ... which might actually let you configure it.

One other thing I've wondered about is if you've ever tried resetting the Thompson to the factory defaults. That's the sort of thing I would try just to see if anything in the router's configuration changed. To do this try pushing the recessed Reset button on the back of the Thompson router between the power socket and the LAN ports with a pen or an unfolded paperclip. Push it until the Power LED lights red or around 10 seconds.

I just find it hard to believe that the current configuration is the "factory default". For one thing, here is what the documentation I found which I think is for this router says to do to navigate to the browser configuration interface:

If the default local LAN IP for the router is supposed to be 192.168.1.254 then how did it get set to 10.0.0.138?? And what else has been "mucked with".

FWIW, here is a link to the where Google found some documentation for a THOMSON TG585v7. I'm not sure if it pertains to the router you have though.

share|improve this answer
    
1: First I turned off the modem's wifi to make sure it doesn't interfere. Then I factory-reset the WRT54G, then connected a laptop to it by LAN cable to WRT54G port 1. I made sure that DHCP was off (and wifi also off; let's get LAN to work first). Saved OK. Then I changed the IP to 10.0.0.250 and saved; then I was not able to connect to it ever again. I'm beginning to think it's defective...? –  Torben Gundtofte-Bruun Aug 23 '10 at 20:02
    
1 cont'd: However, the modem's DHCP is set to range 10.0.0.1 through 10.0.0.254; I tried to modify this range but my changes weren't saved (I tried several times and made sure to click "save"); this must be a limitation in the custom ISP firmware. So I can't pick an IP outside the DHCP range. I've never used ...250 on this network before, and DHCP adresses are given out starting from ...1, so I hope it won't cause too much trouble. –  Torben Gundtofte-Bruun Aug 23 '10 at 20:03
    
2: When I try to change the LAN IP of the WRT54G and save, I am never again able to connect to it, regardless whether the laptop is connected directly and the modem is not connected; or whether the modem is connected (for DHCP to work?). I can only connect to the WRT54G again after a factory-reset (on the original IP, not the ...250 address). –  Torben Gundtofte-Bruun Aug 23 '10 at 20:07
    
3: Check. I wasn't aware of this; in my trials before I asked this question, I used the WAN port. But I don't now. –  Torben Gundtofte-Bruun Aug 23 '10 at 20:08
    
4: Not sure what you mean by "default route". Is this the name of a router setting, or something I configure in the laptop? –  Torben Gundtofte-Bruun Aug 23 '10 at 20:09

Ok, just as a starter, you probably could have achieved the same setup with just purchasing a simple switch instead of a full router. If you take your current setup and just plug all of your devices, including your DSL modem into the LAN side of your router, let your modem handle all of the DHCP, the router will act as just a switch and should give you the functionality you're looking for. That is probably the easiest solution.

The problem you're running into is you actually have two routers. Your modem acts as a router and then you're adding the additional WRT54G. Have two NAT routers is usually discouraged as it can cause probelems, but if you really want to have the WRT54G connected by the LAN port to the modem here is how I would do it.

  • Disable DHCP on the DSL modem
  • Set the modem's IP address to be static and set to 10.0.0.138 (on 255.255.255.0)
  • Set the WRT54G's WAN IP address to be static and set to 10.0.0.139 (on 255.255.255.0)
  • Set the WRT54G's WAN default gateway to be 10.0.0.138.
  • Set the WRT54G's LAN IP address to 192.168.1.1
  • Enable the DHCP server on the WRT54G to server 192.168.1.100+ addresses.
share|improve this answer
    
I got the WRT54G for two reasons: first, it's famous for being versatile, and second, I paid €5 for it. I hope I can get it to work, even though a switch might have been just as good (or better?). –  Torben Gundtofte-Bruun Aug 23 '10 at 19:22
    
It was my intention that the modem would be really just a stupid modem and not do any other work. So it should not need to do any NAT because it only "knows" about it's only client, the WRT54G -- which in turn know all the other clients and does the NAT etc. –  Torben Gundtofte-Bruun Aug 23 '10 at 20:13
    
Your modem is still doing NAT. Unless you can configure it to pass the public IP address it now has onto the WRT54G, it will still hold a public IP address and a private IP(10.0.0.138) which it will NAT. You can still use the configuration I give, but it will be 2 layers of NAT still. –  heavyd Aug 23 '10 at 20:35
    
I followed these steps successfully (no problem because the LAN IP remains unchanged). However, there was no connection to the modem, and hence also no Internet. Even when I disconnected the WRT54G and connected the laptop directly to the modem, it still didn't respond on its address 10.0.0.138. I had to reset the modem to get access to it again -- and I'm now back on using just the modem, not the WRT54G. Still no luck. –  Torben Gundtofte-Bruun Aug 23 '10 at 20:40
    
Thanks for the comment; I don't see any setting in the modem regarding anything like NAT. (Damn custom ISP firmware!) There's a section called "Game & Application Sharing" which might be right. What if I set the modem to map all ports to one client (which is the router)? Would that effectively mean that all traffic just skips the modem's NAT? –  Torben Gundtofte-Bruun Aug 23 '10 at 20:47

For a much simpler solution, why not have the ISP provide you a replacement modem? It's entirely possible that the hardware is faulty.

share|improve this answer

Thomson provides 192.168.x.x by default If you see 10.x.x.x it is most likely providers carrier network and you need to restart your thomson router.

Normally one would disable wireless and dhcp and firewall on provider's router and set it be a bridge instead of a router... Then you can use DHCP and all premium features of OpenWRT

In normal places one can buy their own adsl router and flash with OpenWRT at will

share|improve this answer
    
The ISP has installed custom firmware that is hardcoded to 10.0.0.138, and restarting or even resetting the router does not "fix" it. For the same reason I also can't disable DHCP on the Thomson router, or set it to act as bridge. And I have to use it or else I have no Internet connection. –  Torben Gundtofte-Bruun Feb 24 '12 at 10:51
    
Call the helpdesk say it reboots all the time and you cannot browse longer than 15 minutes. There is nothing wrong with your traffic, it is router crashing. PS I have similar cable modem which used to crash in router mode, but now is fine in bridge mode. Only thing I do not like is 30W rating on power source. –  ZaB Feb 24 '12 at 11:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.