Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the Meta font family as .ttf and .otf files. On a Windows 7 laptop, I copied them into the Control Panel -> Fonts directory. But when I open a word document using a font of the Meta family, it gets rendered in another font (looks like Tahoma) and also prints in the other font.

Double-clicking the font files or copying them again into the fonts directory results in an error message telling me that the font is already installed. I know that the font files are OK, because I had them installed when the laptop still had Windows XP and I never had a problem then.

So, my question is, how do I install the font correctly so Word 2007 can use it?

share|improve this question
1  
Are other applications able to use the font? – Vervious Aug 23 '10 at 17:00
    
@Nano8Blazex I set FBReader to MetaNormal and it displayed the current eBook in MetaNormal. I don't have another application capable of opening Word files to reopen the .doc file and see how it is displayed. – rumtscho Aug 23 '10 at 17:47
    
Silly suggestion but you have tried restarting MSWord right? :) – Vervious Aug 23 '10 at 18:35
    
solved this by running word in safe mode (run that: winword /safe ), create new doc, write and see if your font appear. It did for me, close the word-safe-mode, reopen your doc just by clicking on it. – Guillaume Combot Apr 1 at 13:38
up vote 1 down vote accepted

Is your system up-to-date with the latest patches? Some time ago Microsoft patched their OpenType/TrueType rendering engine because of a security issue, and that caused some fonts to not work anymore. They fixed this later with a better fix that didn't disable those fonts.

share|improve this answer
    
Not sure that this was the reason, but it works now after the hundred things I did (including updating everything). Thanks. – rumtscho Aug 27 '10 at 15:19

Go in MS Word Option/ Advanced then in the Show document content section, uncheck Use Draft Font in Draft and Outline Views

Source and printscreen


This could also work but it doesn't seem to be permanent:

  1. Close Word
  2. Hold the Windows key down and press R.
  3. In the Run box that opens type winword /safe (note there is a space between winword and /) and click on Ok.
  4. press CTRL-N to open a new document.

If you are not able to open the Run box Click on Start > All Programs > Accessories > Run and type in the command winword /safe and click on Ok.

Source

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .