Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to write software that communicates to a server on the internet using a non-standard TCP port. I did not expect it from a home wireless router but it seems to me it blocks my outgoing request, or - at the very least - any responses I'm meant to be receiving.

Could it be that it does that? I'd expect it to block incoming connection requests, but will it block outgoing connections? replies on connections initiated from within the network?

Looking at the configuration options on my router (WGR614V9) I can see port forwarding and port triggering options, but I can see a way to simpliy say - please allow two way communications over port xxxx, should I be able to?

I've looked at the manuals of various other routers online and can't see any explicit configuration entry to that effect anywhere, is that generally not possible?

Forgot to add - when I've plugged my laptop to the broadband modem itself (bypassing the wireless router) the request went through ok as did the response, so I am pretty sure the 'problem' lies within the router

share|improve this question

2 Answers 2

up vote 1 down vote accepted

SOHO routers don't generally have such an option; I'd rather suggest you to check if any firewall is active on your computer.

upd As you say that you're writing your own application, I'll suggest you:

  • Try to connect to that port with telnet (like telnet remote.addr 123), and check if the connection would be refused, and
  • Ask this question on stackoverflow, providing more technical details about internals of your application.
share|improve this answer
    
Thanks, added a small but important fact - I have of course disabled windows firewall (I'm using Win7) and in fact - when I tried to run the program connected to the broadband model directly, bypassing the router altogether, it worked fine. –  Yossi Dahan Aug 23 '10 at 21:13
    
I've updated my answer –  whitequark Aug 23 '10 at 21:33
    
Whitequark - I now believe you are right - turns out that the port was probably open all the time, and my infamliarity with telnet and the like caused me to think it is not working. I have found options on my router to disable the SPI firewall and NAT protection, but I think these mostly affect inbound requests –  Yossi Dahan Aug 25 '10 at 6:41

Most routers, in my experience, DO require you to open non-standard ports (both inbound and outbound). based on your model, it looks like you are using a Netgear router. I use Netgear extensively, and -- again -- you will need to open the ports. I have found that Netgear's manuals are a bit weak on the subject ... you can use port triggering (less effective), port forwarding or static routes. Typically, the firewall will block port activity unless you specifically open the ports. However, port control is typically straight-forward. I hope this helps a bit.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.