Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to connect to a server via SSH on Mac OS X however the username contains a pound sign "£" and and I am having some trouble using connecting. I can connect using other users but not if it has a "£" in the password.

In the past I have had this same problem and forcing the client (such as FileZilla which i do have working) to use the character set "ISO-8859-1" fixes the problem however I cant work out how or even if it is possible with the inbuilt ssh client on OS X.

Any ideas?

share|improve this question
    
copy/paste it in – user46818 Aug 23 '10 at 21:21

Set the ISO-8859-1 encoding in Terminal.app settings, then launch ssh as

export LANG=en_US.ISO-8859-1
ssh [options]... 

You can substitute en_US with your particular ISO language code, but it is not required to get the correct encoding.

share|improve this answer
    
Unfortunately that hasn't worked, however I have discovered that JellyfiSHH (which if my understanding is correct is just simply a bookmark manager and just launches the terminal) works fine when I change the encoding which is puzzling. At least I can connect now. – 3urdoch Aug 23 '10 at 22:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .