Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

None of my VirtualBox virtual machine can use the internet. I've tried every possible configuration of networking ad it never works. Occasionally, just out of the blue, without changing anything, the internet starts working, but stops just as suddenly after a little while. It starts or stops working while I'm using a VM. How can I use the internet from a VM? I am running MacOS 10.5.7 on a MacBook. Edit: I mean that I'm running MacOS 10.5.7 as the Host OS. Edit 2: Whenever I try to use the internet the network icon on the bottom of the window has a little red circle blink.

share|improve this question
1  
Does the answer at Can't access internet from inside Virtual Box apply? –  Dori Aug 24 '10 at 4:38
    
Nope. I've tried that. –  None Aug 25 '10 at 0:20

2 Answers 2

up vote 1 down vote accepted

I've never had any problem accessing the internet with the default (NAT) networking configuration and used bridged mode with no trouble also. I run a Win-XP-32 host with Linux guests.

NAT mode is by far the easiest to set up as the defaults work out of the box. If you are having trouble with NAT mode then you likely have a bad install of VirtualBox.

Bridged mode is convenient if you want to access shared resources on your home network or use the guest OS as some sort of server. However, it is unlikely your ISP allows multiple IP addresses to face the cable/DSL modem. So, in order to use bridged mode you will probably need a router (with NAT enabled) between your ISP and the rest of your network (even if it's just the one physical machine.)

share|improve this answer
    
Agreed that it may be a bad install. Try reinstalling virtual box - it's possible the network drivers it adds got misconfigured or removed or otherwise messed up. –  nhinkle Aug 24 '10 at 4:11
    
I've never used the OS-X version of VirtualBox. I know the Windows version pops up all kinds of warnings about non-certified drivers when installing. All are safe to ignore. –  Chris Nava Aug 24 '10 at 4:56
    
I reinstalled VirtualBox (from the same disk image) and it still does not work. I haven't tried updating it and will see if that works though. –  None Aug 25 '10 at 0:31
    
I clicked "Check for updates" in the VirtualBox menu and it says: "Unable to obtain the new version information due to the following error: HTTP request failed ", but my host internet is working fine. Does this have something to do with VirtualBox's network drivers? –  None Aug 25 '10 at 0:39
    
Sounds like you have networking issues in general. It could be VBox's network drivers are not installed/configured correctly. Sorry, but I have no experience with it on Mac so can't help there. –  Chris Nava Aug 25 '10 at 15:50

When I went on Windows 7 to Network And Internet --> Network Connections , it seemed to work great after I clicked Diagnose. I'm using NAT on a pretty old install of VirtualBox without a problem. Try doing this and see if it works, something about "DHCP" being disabled was corrected after I did this.

You can see a screenshot here: http://i.stack.imgur.com/Zx7qf.png

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.