Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Vista, 64-bit. I recently updated e text editor. Great, I thought. It seems more stable, but has a huge flaw. I can no longer set it as the default programs for file types.

During installation, there is an option to use e as the default editor for .txt files, so was surprised to find that when I right-clicked on say, a .php file, it was not in the list of recommended programs, nor other programs.

I click the Browse button and select e.exe from my Program Files folder, but it has no effect.

Is there any way I can force vista to use C:/Program Files/e/e.exe as my default program for .php etc files? Is there a way I can add it to the list of recognized programs by Vista?

share|improve this question
up vote 0 down vote accepted

Have you tried this one -> change/force filetype associations. If the default vista method doesn't help, then you should use third party tools

share|improve this answer
    
Thanks. Downloaded Creative Element Power Tools and it did the job flawlessly. – Martin Bean Aug 24 '10 at 15:01

Does this article help you at all Martin? Basically lists a few ways of setting the file association, I think Figure D is what you're looking for.

https://web.archive.org/web/1/http://articles.techrepublic%2ecom%2ecom/5100-10878_11-6172036.html

share|improve this answer
    
Yeah. Tried that, no luck. The problem is, when a select the .exe and hit Enter, it just forgets the choice it seems. – Martin Bean Aug 24 '10 at 9:18

This might help: https://web.archive.org/web/1/http://articles.techrepublic%2ecom%2ecom/5100-10878_11-6172036.html

If the program still doesn't open the file then its most likely a command line argument issue. Im pretty sure only the developers could fix that.

share|improve this answer
    
Bollocks. Thanks any way! – Martin Bean Aug 24 '10 at 9:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .