Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After a fresh install of Windows XP I'm having trouble getting the wireless to stay up.

The pattern is it gets a DHCP address, then goes offline just seconds later and goes back to acquiring an address. Loops forever.

If I reboot I get a driver-crash dialog but the wireless apparently works OK. If I try to reinstall drivers I get the up/down problem again.

share|improve this question

migrated from serverfault.com Aug 24 '10 at 9:45

This question came from our site for professional system and network administrators.

8 Answers 8

Is this a vanilla install of XP, or is it Service Pack 1 or higher? If it is simply XP with no SP's, be sure to install up to at least SP2. There were numerous fixes in the first two SP's for wireless compatibility issues.

share|improve this answer

I had similar issues when I had a correct key, but incorrect security settings - I think I did AES when it was actually TKIP. It reported no errors and looked as if I had everything correct, but nothing was working.

Also, if using a Netgear or similar router with mac filtering, make sure that it is turned off as I have seen similar activity where it looks like you are connected, but nothing works.

So, I hate to say it, but if you think the drivers are fixed / not the actual cause of this issue, all I can say is double check your security settings

share|improve this answer

Remove SP3 for XP. Service Pack 2 is the highest you can run if you want stable wireless.

share|improve this answer
    
I'm telling you that the current drivers are flaky with SP3. If you go with SP2 the wireless networking will work fine. –  Tatas Aug 2 '09 at 2:13
    
Wow OK thanks that's an interesting tip. –  Jason Cohen Aug 2 '09 at 20:36

what happens if you set an IP address?

share|improve this answer
    
Same thing happens. It's not DHCP apparently. –  Jason Cohen Aug 3 '09 at 0:30

T42 is a little bit older now, are you using the latest drivers or the drivers that shipped with the machine?

share|improve this answer
    
Yes, the latest from Lenovo. Also tried latest from Intel (the chipset). –  Jason Cohen Aug 2 '09 at 20:35

Remove SP3 for XP. Service Pack 2 is the highest you can run if you want stable wireless.

share|improve this answer
    
Why do I have two posts, and why did i get negative votes. This is probably the fix. I have the exact same laptop and this issue is documented elsewhere on the web. –  Tatas Aug 2 '09 at 0:30

General advice is to make sure you have the most up to date Wireless drivers from the WiFi card vendor. You should also try disabling power management features within the cards driver. If you are having this sort of problem it can mean that there is a problem with your WiFi card and the infrastucture you are connecting to negotiating power levels. The Intel Centrino WiFi (the Pro Wireless 2100b) in the T-42 had issues with PSP Mode (Power Save Polling) with early driver versions when connecting to quite a few vendors' Access Points, it was definitely an issue with older Cisco kit. The recommendation was to either enable CAM (Continually Aware Mode)\disable PSPM if those options are available or to simply set the WiFi power level to max. This should not be an issue with the most current drivers but it is always worth checking, just in case your AP has issues handling PSPM.

There is some additional information on the broader subject in this TechRepublic article.

share|improve this answer

Are you using the thinkvantage connection manager or the built in windows wireless settings app? I've had problems with some of the newer thinkvantage updates (i tend to keep the old version as a result) - try switching to letting windows handle it and see if that fixes it. If it does, see if you can revert to an older version - there's usually installers for them in the drivers folder at the installation root.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.