Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Windows 7 and a few times a day the "Use a proxy server for your LAN (These settings will not apply to dial-up of VPN connections)." under "Local Area Network (LAN) Settings" checkbox becomes checked seemingly on it's own.

Screenshot of the Local Area Network (LAN) Settings

Am I pressing some kind of hidden keyboard shortcut accidentally? What sort of applications might alter this setting and why?

Unfortunately as this is a developer box, there's a lot of stuff that could be interfering, e.g. Visual Studio 2010, Windows Azure SDK and various browsers.

Has anyone else come across this?

share|improve this question
    
Wow, this is an old question, and I am having this exact problem. Except I am not running Visual Studio (that I know of). Anyone have any updates to this? Should I re-ask this question perhaps? –  Larian LeQuella Nov 16 '13 at 4:37

7 Answers 7

Check out this link if you're using Visual Studio 2010 unit testing features

Proxy Server settings being set automatically which is causing me not to be able to run manual test.

Can you turn OFF the Diagnostic Data Adapter "ASP.NET Client Proxy for IntelliTrace and Test Impact" and check if you are still facing this issue? To do this perform the following steps.

Plan->Properties-> Manual Runs : Test Settings -> to open the test settings wizard.

In the test settings wizard, go to "Data and Diagnostics Tab" and turn off "ASP.NET Client Proxy...". Click on Finish and remember to save the plan. Now execute the tests and see if you are still facing this issue.

share|improve this answer
up vote 3 down vote accepted

It appears to be being caused by running unit tests in Visual Studio 2010.

share|improve this answer
    
Hi, I'm using VS 2012 and 2013, and getting the same weird behavior of having my proxy settings turned on. It may be that VS unit tests are causing this, but how did you fix the problem? –  Shaul Behr Feb 20 at 14:01

Are you on a Windows domain? If so then your system could be pulling down a policy for proxy settings each time you logon.

share|improve this answer
    
So how do we change them ? –  Vivekh Oct 29 at 14:17

I have seen infections change this setting within the last couple of months on one of my machines and several machines at work. I would run a full AV scan and check for Malware using two different scanners.

share|improve this answer

This happened to me on Windows 7 Enterprise. While attempting to install other software, something called RocketTab snuck onto my machine. It was running a program called Client.exe which constantly tries to make itself a proxy server so it can modify search results, etc. to whatever it likes.

I found this by using Task Manager to look for processes that I didn't recognize. I right clicked and selected to open the file folder. When the folder was Programs ... RocketTab, I was quite suspicious. Once I uninstalled RocketTab the proxy setting remained unchecked. There might be similar programs out there that try to do the same thing. Seek and destroy :)

share|improve this answer
    
Aaah. That worked for me –  Vivekh Oct 29 at 14:16

Fiddler is another program that does this. See http://docs.telerik.com/fiddler/knowledgebase/proxy

share|improve this answer

My original problem was found when Google search function with Chrome environment with Window 8.1 became unreliable as it often returned message of "Webpage is not available with error code: ERR_CONTENT_DECORDING_FAILED". The first couple of searches were fine but once this error message appeared, I could no longer use Google search. This error message is not listed Chrome technical support.

However, it appears to be caused by sending wrong codes from my PC to the search engine at Google site. After struggling, I found it may be caused by wrong LAN setting in the Internet option: i.e. (1) "use a proxy server for your LAN" was ticked, (2) "Automatically detect setting" was not ticked. It should be wrong ways around, so that I reset to default condition: (1) use a proxy server... not-ticked, (2) Automatically detect ..... Ticked. The Google search function became improved but still returned the situation of the error after several test searches. I noticed it has time dependent for the re-occurrence of the problem.

I checked the LAN setting each time and found that the setting was automatically changed back. Eventually I used "Task Manager" to check currently running software which relates to Internet connection and found software called "BrouserSafeguard with rocket Tab" as stated in one of your answers. This seems to change back the setting automatically when it scans around every minute. This caused Google search engine but other search engines such as "Bing" and "Ask Jeeves" were not affected by setting in Chrome. This is neither malware nor virus, so that my Norton anti-virus does not detect it. I uninstalled it from "Control Panel" manually and the problem was solved. I thank you for your most useful answer in this site.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.