Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I added the Vim plugins and such from this page http://github.com/akitaonrails/vimfiles. I followed the instructions on the page and it all worked out fine, except the part on getting Command-T to work. But that's okey, I'll just map CTRL-F instead...

The problem is that I no longer can write "@" or any of the special characters that is typed using "alt".

alt-2 now writes '²' (raised 2).

Any ideas?

*Edit: *

I have tracked down the issue to the following

if has("gui_mac") || has("gui_macvim")
    set guifont=Menlo:h14
    " key binding for Command-T to behave properly
    " uncomment to replace the Mac Command-T key to Command-T plugin
    "macmenu &File.New\ Tab key=<nop>
    "map <D-t> :CommandT<CR>
    " make Mac's Option key behave as the Meta key
    set invmmta
    try
      set transparency=5
    catch
    endtry
endif

I uncommented those two lines in my attempts to get Command-T to work... Now the question is, how do you reverse it? Just commenting them again doesn't work.

share|improve this question
    
the issue only occurs in macvim btw! –  ullmark Aug 24 '10 at 13:59
    
the issue also only occurs in macvim not in vim. –  ullmark Aug 24 '10 at 14:07

1 Answer 1

up vote 1 down vote accepted

The solution was to comment-away the row with "set invmmta"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.