Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Today for the 4th time this month,
Ubuntu suddenly disables my Ethernet,
I'm connected through Alcatel Speed Touch (yeah I know it's an oldie).
I tried to log out and log back in, tried ifconfig and it didn't recognized
any Ethernet modem connected.
Only after a reset did it work... like every time before.
Any ideas?

UPDATE
Tried to enter
/etc/init.d/gdm restart
and then after the gui restarted
sudo dhclient eth0

That worekd, but I still want to know what's wrong
and why does it stop working all the time

UPDATE 2
the dhclient eth0 thing doesn't work anymore.
Any ideas?

share|improve this question
    
output of dmesg? –  IanH Aug 24 '10 at 15:39
    
next time it happens I promise, but I can't predict that, any guesses ? –  Asaf Aug 24 '10 at 15:50
    
guess what, happened again, dmesg gist.github.com/724a661f86d6305c4538 –  Asaf Aug 25 '10 at 15:13

1 Answer 1

up vote 1 down vote accepted

This is known bug with r8169 ethernet cards. For reference, it is bug #566389 on the Redhat bug tracker or #605045 on the Network-Manager Ubuntu bug tracker.

A current workaround is to place this in /etc/pm/sleep.d/85-network-r8169-module [1]

#!/bin/bash
case $1 in
  hibernate | suspend)
    echo "Removing r8169."
    modprobe -r r8169
    ;;
thaw | resume)
    echo 3 > /proc/sys/vm/drop_caches
    modprobe r8169
    ;;
*)
    ;;
esac
exit 0

However, it will make resuming a bit slower.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=566389#c6

share|improve this answer
    
If it's NetworkManager bug, why not just switch to Wicd? –  AndrejaKo Sep 5 '10 at 8:16
    
Ok so I'll just make a command that I'll run if it won't connect, what's the exact command I should run to make it work? modprobe -r r8169 and then modprobe r8169 ? –  Asaf Sep 7 '10 at 19:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.