Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to use sshfs (2.2.0) and macfuse (2.0.3) along with emacs (23.2.1).

Many times when I try to save a file that I am editing from the remote file system I get the error:

file.txt has changed since last visited or saved; save anyway?

Occasionally I then get the error:

file.txt is write-protected; save anyway?

Are there any options I can use when mounting the file system that would make this work without the errors? I have tried turning caching off (-o cache=N) which made the error show up every time I tried to save a file.

share|improve this question
Is this a new phenomenon? What's the OS on the remote machine? Are there any cron jobs running on the remote machine which would alter the file or its permissions? – Doug Harris Aug 24 '10 at 21:22

You must log in to answer this question.

Browse other questions tagged .