Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a 6 month old Macbook Pro which works fine with WiFi everywhere that I've tried it besides on my college campus. The WiFi worked fine in the Spring on campus, but they changed to a new system where you have to login to access the WiFi (where it redirects you to a login screen that is a webpage). What is strange about this is that I am able to connect immediately without ever seeing the login screen, but the WiFi drops every 1-2 minutes. The only way to get the Wifi back is to renew the DHCP lease. I am able to use the Wifi at places like Starbucks or Barnes & Noble where they have the same type of login screen (except I actually get the login screen there). The "IT people" have no idea, and I've tried things like deleting the network and rejoining, but haven't had any luck. Any ideas?

I noticed this error shows up everytime in the Console when the connection drops (no idea what it means though):

com.apple.launchd[1] (com.apple.netauth.sysagent[31376]) Exited with exit code: 255

share|improve this question
    
Can you open Windows on the Macbook? If so, does the same thing happen? –  digitxp Aug 24 '10 at 22:41
    
I tried in Parallels and it did the same thing. –  James Simpson Aug 24 '10 at 23:34
1  
Parallels doesn't load the Windows drive for your wireless card. For this to be a good test of a different OS and driver, you'd have to boot into Windows via Boot Camp. –  Spiff Aug 25 '10 at 1:02

4 Answers 4

up vote 3 down vote accepted
  1. Disassociate from the network by turning AirPort off or selecting a different network, or even by creating your own IBSS (Ad-hoc, computer-to-computer, etc.) network.

  2. Run the following command to enable AirPort debugging:

    sudo /usr/libexec/airportd debug +AllUserland +AllDriver +AllVendor

  3. Now join the network as you usually do and use it until it drops off.

  4. After you reproduce the problem, you can disable those debug levels by changing the plusses to minuses and rerunning the command.

  5. Post the /var/log/kernel.log and /var/log/system.log files so we can see what happened.

share|improve this answer
    
Okay so I just followed the steps, but nothing was in either log for today. –  James Simpson Aug 25 '10 at 21:51

If you can use your mac in other places the problem located on campus WiFi system. Tell your IT people check WiFi access point log file. I assume campus equipment is Cisco. Give them your WiFi airport MAC address it helps inspect log file.

share|improve this answer
    
A bunch of other people around me have a similar Macbook Pro and don't have the same problem though. –  James Simpson Aug 25 '10 at 21:52

The problem might have something to do with the authentication page not loading. Can you surf to the URL of the authentication page manually and see what happens if you log in?

share|improve this answer
    
Yes, I was able to get to that page by getting the URL off of another computer, but the problem still happens after logging in. –  James Simpson Aug 26 '10 at 21:20

This is a problem that I noticed when I was using a WiMax service where the lease was only good for 3 hours. I was connecting my router to the WMax modem, and upon lease renewal, it was resetting something in my IP connection, and I was therefore losing all my internal wireless connections, under Windows. Linux seemed to survive better, actually. Then, we moved to a cable-based service provider, where the lease was actually longer, and the problem stopped.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.