Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an HP EliteBook 8540p laptop with associated docking station. It is running Ubuntu 10.04. Until now I have been successfully running TwinView with the nvidia-195.36.24 drivers - using the built-in LCD screen and an external LCD monitor, connected via an analog VGA cable.

I've changed the screen over to a larger resolution Philips LCD, and it works fine over VGA. However the image is not as sharp as I'm used to with other monitors, so I'm trying to get it working over the DVI port on the laptop docking station.

However I have been quite unsuccessful in getting a picture to appear on the external monitor - Xorg is able to read the EDID information from the monitor, and according to Xorg.0.log has absolutely no problems with finding a valid mode and choosing this monitor as "DFP-1", alongside "DFP-0" (laptop display). But no matter what I do I can't get a picture. Xorg.0.log has no errors.

I have unsuccessfully tried:

  • various combinations of xorg.conf options to set "ConnectedMonitor", "CustomEDID" with a EDID .bin downloaded over VGA, etc.
  • a colleague has the exact same laptop and monitor, and has it running fine. However using his xorg.conf still produces no picture.
  • nvidia-settings - tried lots of things
  • a different DVI-connected monitor

It's as if the DVI port is fully functional in every way but its output is somehow disabled. I've also tried other monitors, they don't work either, yet do with a VGA cable.

EDIT: I have checked the DVI cable and it is OK.

I would like to know if there's anything else in terms of enabling a DVI port that I should look into?

share|improve this question

1 Answer 1

Turns out the answer was really simple - a bent pin in the DVI connector was misaligning with the socket on my laptop docking station, yet somehow managed to align properly when I tried it on another PC. So the problem is solved - DVI works perfectly now the cable is fixed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.