Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a lenovo S9e running Intel integrated graphics. Here is my lspci output related to the graphics:

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
Subsystem: Lenovo Device 3870
Flags: bus master, fast devsel, latency 0
Memory at f0580000 (32-bit, non-prefetchable) [size=512K]
Capabilities: [d0] Power Management version 2

I want to know how I can make sure OpenGL support is running in full on an Ubuntu 10.04 installation. I have a few hints to think that it is not:

  • The "Desktop Effects" will not load

  • Apps such as stardock, when attempting to use OpenGL rendering, will display black boxes instead of transparency

  • In the games Pioneers, the number-tile icons are suspiciously just black circles

  • Windows games running with Wine will only support software rendering, not hardware rendering

  • When I boot into a Knoppix LiveCD, the desktop effects do work, splendidly, meaning compiz detects my computer as capable.

My problem with troubleshooting is that Canonical has basically eliminated the conf-file-based mechanism of X11 as far as I can tell, thus making it even harder to ensure graphics modules are loading properly.

How do I debug and test OpenGL on m Ubuntu 10.04 installation?

share|improve this question
    
Does glxgears run properly? You can create /etc/X11/xorg.conf anyway and Ubuntu will use it. – cYrus Aug 25 '10 at 9:07
up vote 4 down vote accepted

Run

glxinfo | grep '^direct rendering:'

and if it shows Yes then you have 3D acceleration, and hence OpenGL.

share|improve this answer
    
it says yes. Any suggestions as to why then various effects won't run under 10.04 but will under Knoppix? – Jonathan Aug 25 '10 at 6:08

You might want to try disabling KMS.

(That's not really an answer to your question, sorry, but it might solve your issues. ;) )

share|improve this answer
    
This is a huge help! I disabled KMS and at the very least, upon testing, I can now use visual effects in 10.04! I am now off to test some Wine games. Cheers! – Jonathan Aug 26 '10 at 5:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .