Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had a westcon pendrive.

recently i scanned that device with kaspersky anti virus software and deleted virus, from there onwards when ever i tried to open it says "Please insert a disk into drive G:".

When i tried to format replay was "There is no disk in drive G:".

Is there any way to get back that device to work?

Thanks

Edit

I'am using Windows XP OS

share|improve this question
    
You've tried on another computer? You've ejected and re-inserted? –  random Aug 25 '10 at 5:25
    
@random yes i tried on another computer and it gives same message on every system. –  srinivas Aug 25 '10 at 5:28

1 Answer 1

Some things to try:

  • In the Device Manager, please be careful to find the correct drive (i.e. NOT your hard disk), then right-click the drive and choose Uninstall. To finish, unplug it and plug it back in again.

  • If that doesn't work: press the Windows Key + R to enter the Run dialog -> Enter diskmgmt.msc and click OK -> Find the drive in the list of disk drives -> Right-click and choose Change Drive Letter and Paths... -> Click Change -> Choose a new letter then click OK.

  • If it still doesn't work and you are desperate to get your data back, then Photo Rec has a good reputation for recovering data and should be worth a go. I doubt it will get the drive running normally again though.

If your data is not important and you just want to get the drive useable again:

  • Some people claim to have had success by booting their computer from a Windows installation DVD with the drive inserted and using the installer to format it. There is a point early on in the installation where you can see all drives connected to your computer and you have the option to create, delete or format partions on each one. See if you can delete the existing partition and create a new one.

  • Ultimately it might be easier to contact Westcon and find out if they will replace it under warranty.

share|improve this answer
    
i tried the first 3 procedures :( no luck. the software you preferred is not even detecting the pen drive. i'll try the procedure 4, not sure with procedure 5. i'll vote this up when i got enough rep. :) –  srinivas Aug 27 '10 at 5:59
    
I'm disappointed it hasn't worked so far. What do you see in the Disk Management program - diskmgmt.msc? Does it show any partitions on the drive? If it does then try deleting it (you'll lose the data though). Then create a new one and see if you can format it. To access these commands you right click in the rectangles that represent partitions or empty space. Make sure it's the right drive though! –  James Aug 27 '10 at 8:48
    
One thing I meant to mention is that you might need a fairly recent Windows installation disk to be able to see USB drives. If your XP installation disk is from before Service Pack 2 then it might be an idea to borrow someone elses. –  James Aug 27 '10 at 9:47
    
What is the storage capacity? FAT32 is designed to use until 2GB! A lot of new pendrives have more than that because they "break the specification". So it is difficult to recover the files. Search in internet how to change pendrive partition to NTFS... –  kokbira Dec 7 '10 at 12:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.