Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This one's part anecdote, party question: I just recently got Ubuntu 9.10 running on a box I plan to use as a build server. I've been working with a system that's booting off an SD card lately, so my build process is normally make a change, mount SD card, copy new boot image, unmount SD card, put card in system, boot. Obviously, this requires a lot of mounting an unmounting of media drives as my development process goes on. I eventually plan to run my build server headless, so for now I've got my monitor attached to a KVM switch which in turn is attached to my build server and my workstation, and I've been doing most of my work on my workstation, ssh'd into my build server.

I noticed that as time went on, my build server started to really slow down. I flipped my KVM switch to take a look at it and realized, with much surprise, that Ubuntu had opened up a new window for every time that I had mounted my SD card. As I hadn't had my monitor flipped to my build server for about a week, I had somewhere in the range of 50 windows open on the desktop, all with errors about that location no longer existing.

Fun times.

Now for the question: How do I go about changing Ubuntu's media automount behavior? I like that my SD card is being mounted each time I plug it in, but I want to disable its default behavior of opening the media in a file explorer each time it mounts. Unfortunately, trying to type Ubuntu mount behavior or ubuntu automount windows into google gives very misleading results. Any ideas?

Thanks in advance!

share|improve this question
up vote 1 down vote accepted

From this page:

Alternatively, if you only want to disable the Nautilus window that opens up every time you plug in a storage device, the simpler method for this is to open up Nautilus, go to Edit > Preferences > Media and turn off Browse media when inserted.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .