Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to enter a date in a document with the following format:

1 September 2010

However, OpenOffice insists on changing it to:

01/09/10

I've looked in the AutoCorrect options and elsewhere and have been unable to find a way to disable this annoying behaviour. Any suggestions?

share|improve this question
1  
What application are you talking about (Writer, Calc, Impres...)? And which language settings do you use? – sleske Aug 25 '10 at 21:48
    
@sleske Writer. My language is set to English (UK). – Dan Dyer Aug 25 '10 at 22:09
up vote 20 down vote accepted

This is a special auto-correct behaviour that is only active for tables in Writer (not in Calc). It is controlled under:

Tools > Options > OpenOffice.org Writer > Table > Input in tables > Number recognition

Uncheck that option to disable the autocorrection.

share|improve this answer

changing the date format is simple just follow these steps: in OpenOffice Writer go to Insert > Fields > Other > select Date from the first box > Date fixed from the second box > Choose the format that u want to use from the third box then Click Insert.

edit: you also can add more formats from the same window if u want by double clicking on Additional Formats.....

share|improve this answer
    
That's not really what was asked. The poster didn't ask how to insert a date in a certain format, but how to disable the autoformatting when typing it in. Your answer does not do this. – sleske Aug 25 '10 at 23:15
    
thats what i thought when i first read the topic but when i copied and pasted that date into a new writer file it wasnt changed by the auto-correction, also i typed some dates and saved the file and made a print preview and it didnt change so i thought maybe he means how to use another auto formating way than the pre-defined one – eslambasha Aug 25 '10 at 23:29

For Openoffice Writer:

Change date autocorrect style

  1. Go to Table.
  2. In Number Format Menu - change Language to English UK or whatever you need - choose date style you want in Format.
share|improve this answer

You can start with an apostrophe to ensure that it is recognised as a text and hence doesn't autocomplete.

share|improve this answer

Just click right mouse button where you fill date and:

formatcell -> number -> date -> formatcode -> DD MMMM YY -> then click OK button.

Your date related problem should be solved.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .