Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Western Digital Caviar Black 1TB 7200rpm hard drive with unbearable seek noise! See Quiet Hard Drive suggestions.

I have replaced the drive now, but don't want it to go to waste. Does anyone know how to enable AAM (Automatic Acoustic Management) on Western Digital Drives?

I have an Asus P5QL-Pro motherboard, and have so far had no luck with Hitachi FTool (Feature Tool). any help would be greatly appreciated.

share|improve this question

4 Answers 4

up vote 5 down vote accepted

A thread at Hexus here, describes another user's identical problem, and several possible solutions. The final "stop-gap" solution that worked for that user was using the Windows version of hdparm and setting up a batch file to run at startup, since the settings got erased at restart.

share|improve this answer
    
I tried this, using the command ">C:\Program Files\hdparm\bin>hdparm -M hda" and get the floowing output: ">hda: Permission denied" –  GaryJL Aug 4 '09 at 17:33
    
I haven't personally used the Windows version of hdparm. If you're using Vista, make sure you run the program, or your commandline, with administrator permissions. Beyond that, I'm not sure. –  Keck Aug 4 '09 at 17:36
    
You're right! I'm using Windows 7, and running as administrator worked. I normally try any program that functions abnormally under admin rights, but not this time... –  GaryJL Aug 4 '09 at 18:21

I used HDDScan to enable AAM on my WD10EADS-00P8B0 (1 TB Green Power). Its freeware, and does not require installation.

To use:

  1. Download tool.
  2. Unzip to any directory.
  3. Run HDDScan.exe as administrator
  4. Select the drive you want to adjust in the "Select Drive" drop down.
  5. Select Tasks > Features > IDE Features.
  6. If AAM is disabled the "On" label in the Automatic Acoustic Management box will be red. Change the value in the "Current" text box to match the value in the "Recommended" text box.
  7. Press the "Set" button. The "On" label should turn green and your drive should instantly become noticeably quieter.

I have 2 of these drives. One was noticeably louder than the other. I'm pretty sure SpinRite turned off the AAM feature and did not turn it back on, since the drive got noisy immediately after running SpinRite. The drive is now quiet, but I haven't had a chance to reboot yet to see if the setting is stable throughout a power cycle.

Hope this helps.

UPDATE: After rebooting I can confirm the setting has persisted.

share|improve this answer

Many newer drives come locked into performance mode. I would recommend downloading the toolset for that particular drive and see if they provide a tool to make changes to the default drive settings.

share|improve this answer
1  
WD don't supply any tools to do this job. They recommend an Intel tool, but my chipset is incompatible. –  GaryJL Aug 4 '09 at 17:16

CrystalDiskInfo has an acoustic management option in the advanced menu.

Program is free and works perfectly.

In fact the Western digital WD1001FALS hard drive is set to run as quiet as possible until I can get round to implementing the rubber band silencing technique 8-)

see here for more info: http://lifehacker.com/378786/silence-your-hard-drive-with-elastic-suspenders

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.