Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't Ctrl + C or Ctrl + V to copy and paste respectively.

I know that if I want to do so in Firefox vimperator I'll have to add these lines:

noremap <C-c> <C-v><C-c>
noremap <C-v> <C-v><C-v>

However, I'm not sure exactly what the file is or where I can find it to place that code in.

share|improve this question

5 Answers 5

Vimperator uses Ctrl-V to tell it to pass the next command straight to Firefox. If you go Ctrl-V Ctrl-C that copies, and Ctrl-V Ctrl-V will paste. However, you may be better off remapping if you don't need Ctrl-V passthrough for anything else.

share|improve this answer

:mkvimperatorrc will create the initial ~/.vimperatorrc file, then you can manually add anything to it.

:source ~/.vimperatorrc allows you to re-read it, without restarting Firefox (:restart).

You might want to use the X clipboard instead (via Shift-Insert (Paste) and Shift-Delete (Cut)).

Also, Y will yank any selected text the vimperator way (both to clipboard and X11 selection).

You might be interested in my vimperatorrc: http://github.com/blueyed/dotfiles/blob/master/vimperatorrc

share|improve this answer

The following worked for me, but I have no idea why as I don't understand the difference between no, cno, and ino remap

" mswin.vimp - mappings to make copy/paste in Vimperator behave like Windows
" Maintainer: Doug Kearns <dougkearns@gmail.com>
" Last Change: 31 Oct 2008

noremap <C-q> <C-v>
noremap <C-Q> <C-z>
" TODO: this should probably be <C-Break> - see :help dos-CTRL-break in Vim
noremap <C-s> <C-c>

inoremap <C-q> <C-v>
inoremap <C-Q> <C-z>
inoremap <C-s> <C-c>

noremap <C-a> <C-v><C-a>
noremap <C-c> <C-v><C-c>
noremap <C-v> <C-v><C-v>
noremap <C-x> <C-v><C-x>
noremap <C-z> <C-v><C-z>
noremap <C-y> <C-v><C-y>

cnoremap <C-a> <C-v><C-a>
cnoremap <C-c> <C-v><C-c>
cnoremap <C-v> <C-v><C-v>
cnoremap <S-Insert> <C-v><C-v>
cnoremap <C-x> <C-v><C-x>
cnoremap <C-z> <C-v><C-z>
cnoremap <C-y> <C-v><C-y>

inoremap <C-a> <C-v><C-a>
inoremap <C-c> <C-v><C-c>
inoremap <C-v> <C-v><C-v>
inoremap <S-Insert> <C-v><C-v>
inoremap <C-x> <C-v><C-x>
inoremap <C-z> <C-v><C-z>
inoremap <C-y> <C-v><C-y>
share|improve this answer

vimperator reads file ~/.vimperatorrc during startup. Create/modify that file at will.

share|improve this answer
    
i don't have such aaa file. i have a .vimperator folder. is this due to an updated version? –  Tony Pham Aug 26 '10 at 9:19
    
Did you try to create that file as I suggested? :-) Don't know, but the current vimperator manual still states that vimperator reads ~/.vimperatorrc during startup. Try and see, it won't hurt you! –  Janne Pikkarainen Aug 26 '10 at 9:20

I have been bothered by the problem for so long time even I dont recall when It started.

my final solution is

inoremap <C-v> <C-v>

and it works great!

once when I It paste twice! That is very annoying!

I tried

inoremap <C-v> <C-v><C-v>

that seems like make sense, but It's useless cause It doesnt' work!

In the process of fixing this , I tried inoremap <C-v> i<C-v><esc>, this makes difference. after some tries, it came down to that final solution.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.