Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to pull changes from a server which has sshd on port 2345 and an hg server listening locally on port 5432. I already have certifcate-based authentication for ssh, so there no need for a password.

This doesn't work:

hg -v pull ssh://me@myserver.com:2345/ -p 5432

since the pull command apparently takes the port number from where I assumed ssh would be taking it...

Any ideas how to do this?

share|improve this question

The simplest thing would be to put an entry in ~/.ssh/config, something like:

Host myserver.com
Port 2345
share|improve this answer

You just need

hg -v pull ssh://me@myserver.com:2345/full_pathname   

eg.

hg -v pull ssh://me@myserver.com:2345//srv/hg/username/repos 

-p is not a recognized option for hg pull. Note your path syntax above is also wrong

hg -v pull ssh://me@myserver.com:2345/

is not correct syntax.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .