Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hello this is the response I get from ifconfig. Now I have two eth0 things being showed up. I need to delete the second one which says eth0:avahi. I posted my ifconfig's response on a site as I has problem using wired internet, and they suggested to remove the eth0 avahi, to get internet.

But I am a newbie to linux networking and have no idea how to delete this.

response for ifconfig

eth0 Link encap:Ethernet HWaddr 18:a9:05:22:cd:f9
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:28 Base address:0x4000

eth0:avahi Link encap:Ethernet HWaddr 18:a9:05:22:cd:f9
inet addr:169.254.10.43 Bcast:169.254.255.255 Mask:255.255.0.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
Interrupt:28 Base address:0x4000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:796 errors:0 dropped:0 overruns:0 frame:0
TX packets:796 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:64016 (64.0 KB) TX bytes:64016 (64.0 KB)

wlan0 Link encap:Ethernet HWaddr 00:26:82:3c:ac:27
inet6 addr: fe80::226:82ff:fe3c:ac27/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:52142 errors:0 dropped:0 overruns:0 frame:0
TX packets:30404 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:60816983 (60.8 MB) TX bytes:4160159 (4.1 MB)
share|improve this question

2 Answers 2

up vote 0 down vote accepted

What's in your interfaces file? (Not sure if this is the correct place in Ubuntu 10.04)

$ sudo gedit /etc/network/interfaces

If avahi is list there, try deleting it.

share|improve this answer
    
auto lo iface lo inet loopback this is the content in /etc/network/interfaces file –  macha Aug 26 '10 at 17:21

The reason that you see the eth0:avahi device is that eth0 has no working IP networking (it has no IP-address). Once eth0 works, eth0:avahi should go away automatically, so you shouldn't care about it.

Now, about the best way to fix this, it would be useful to know whether this is a desktop or a server...

share|improve this answer
    
I am using a desktop –  macha Aug 26 '10 at 21:28
1  
Most likely your network doesn't have a DHCP server, or it is not working corrently, so if you want to be able to use the internet either you need to configure a fixed IP address in the subnet that your network uses, or you need to fix the DHCP server. You can set a fixed IP address in the Network Connections control panel (under System -> Preferences). In case you know you have a DHCP server (e.g. in your home router), you should check why it doesn't work (maybe it restricts which MAC addresses can get an address?). –  JanC Aug 27 '10 at 10:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.