Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I used to have both windows vista and ubuntu 10.04 on my laptop and i could choose which one to start at start up. But now I only have ubuntu 10,04 on my laptop and because there is only one operating system on my laptop the grub window doesn't show up. I need it because sometimes I need to start my ubuntu in recovery mode with no graphics, I checked and grub is already installed, how can I activate it at start up ?

( by the way : I have grub2 )

Thanks in advance

share|improve this question
add comment

2 Answers

up vote 8 down vote accepted

The menu will appear if you press Shift when grub is loaded. By default you have 10 seconds.

If you want to always see the menu, edit /etc/default/grub. The settings are documented on the Ubuntu website. You may want to:

  • Set GRUB_HIDDEN_TIMEOUT_QUIET=false so that Grub shows a countdown to the automatic boot. Press Shift during the countdown to make the menu appear.

  • Set GRUB_HIDDEN_TIMEOUT= (nothing after the equal sign) to always display the menu.

  • Change the setting for GRUB_TIMEOUT=10 (number of seconds before the automatic boot). The value -1 means that there will be no automatic boot.

Note that spaces are not allowed on either side of the equal sign.

You need to run the update-grub command for the settings to take effect.

share|improve this answer
add comment

or you can just hit [shift] during boot when you need to choose boot options so you dont have to worry about it the rest of the time

share|improve this answer
1  
ESC is for Grub1. Use Shift for Grub2. –  Gilles Aug 26 '10 at 17:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.