Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hello I am using Ubuntu 10, and am having problems with getting connected to wired internet. Normally when I connect a cable to my computer, the port would have a green and yellow light flashing. But now I only have the green on flashing once in a while. So I actually want to know if my network card has been detected.

eth0 Link encap:Ethernet HWaddr 18:a9:05:22:cd:f9
UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B) Interrupt:28 Base address:0xe000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:4 errors:0 dropped:0 overruns:0 frame:0 TX packets:4 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)

wlan0 Link encap:Ethernet HWaddr 00:26:82:3c:ac:27
UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wmaster0 Link encap:UNSPEC HWaddr 00-26-82-3C-AC-27-00-00-00-00-00-00-00-00-00-00
UP RUNNING MTU:0 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

This is what is displayed when I do ifconfig, but it isn't giving me any address.

share|improve this question
    
Are you connecting directly to modem or to a router/switch/something else? –  Chris Aug 26 '10 at 18:59
    
I am connected directly to a switch. –  macha Aug 26 '10 at 19:03
    
And what is your switch connected to ? Also are you using network manager or anything else to manage network devices? If so do you hav DHCP enabled or a static IP set in your network managing software ? –  Chris Aug 26 '10 at 19:05
    
it is DHCP. I have been using wired internet for sometime, but I had to reinstall Ubuntu again. From the time I reinstalled Ubuntu, I am not able to get wired internet. –  macha Aug 26 '10 at 19:08
    
see my edit below, bring down your eth0 using ifdown and then bring it back up. Then check if it pulled ip using ifconfig. –  Chris Aug 27 '10 at 15:29

4 Answers 4

up vote 3 down vote accepted

Check if you can get out onto the net: ping google.com

If this fail's a few things could be happening.

As other's have said though, ifconfig will get you device details.

ifconfig

This should display something like:

eth0      Link encap:Ethernet  HWaddr AA:22:DD:CC:EE:FE
      inet addr:121.121.128.120  Bcast:128.146.128.255  Mask:255.255.255.0
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:28834210 errors:0 dropped:0 overruns:0 frame:0
      TX packets:34965403 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:17051041467 (15.8 GiB)  TX bytes:4435012315 (4.1 GiB)
      Memory:fc200000-fc220000 

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:16436  Metric:1
      RX packets:6450 errors:0 dropped:0 overruns:0 frame:0
      TX packets:6450 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:2266926 (2.1 MiB)  TX bytes:2266926 (2.1 MiB)

Notice how I have an inet addr defined. If you do not have an IP address then something is wrong.

If this is the case... most likely it would be a DHCP problem. Are you using network manager or anything to "manage" your network?

Can you ping 192.168.1.1 or ping 10.0.0.1? (Most likely your router's LAN ip is one of those)

If you can ping one of those, then you can see your router and you are not getting a IP from the router. This could be either your router DHCP not configured/setup or your system not requesting an IP from the router.

That is if you have a router.

Last thing to do:

ifdown eth0
ifup eth0
share|improve this answer
    
What could that be?? –  macha Aug 26 '10 at 18:55
    
What could what be ? –  Chris Aug 26 '10 at 18:56
    
I am connected to a d-link switch. I was talking about the problem. –  macha Aug 26 '10 at 19:04

Open a terminal window and type ifconfig. You should see an entry for eth0 which is your (first) hardwired Ethernet port. If it is working, (and DHCP is enabled) it should have an IP address assigned and you will see RX/TX packet activity.

share|improve this answer
    
I do not have an ip address, what could the problem be? –  macha Aug 26 '10 at 18:56

If the failure immediately followed a re-install, the likely place to look is in the new installation's network setup. A quick test to confirm that would be to try connecting to a known-working router, and try connecting to your switch from another, known-working computer. Either of those tests whether the failure in your OS or upstream of it.

share|improve this answer

Your question is a little unclear, but you can check to see if your hardware has been detected with the command "lspci". If is isn't already installed, its available in the "pciutils" package.

If you see something like this:

00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 7c)

Then your hardware has been detected.

The check for link detection, I use ethtool.

root@pro-38-gl:/home/albertlash# ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes:   10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
Supports auto-negotiation: Yes
Advertised link modes:  10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: d
Current message level: 0x00000001 (1)
Link detected: yes

Though mii-tool will work as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.