Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just reinstalled Windows XP on my Dell XPS M1710 laptop. Now whenever I (accidentally) hit the power button the machine shuts down without warning; previously you had to hold it for a few seconds before it shut down.

Does anyone know how I can restore the original behavior?

There is already a similar question on SU, but there's no talk about the delay there, just changing the button's function.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

A hold-for-4-seconds shutdown is usually motherboard driven (which is why it works at any time and even if your OS completely locks).

My guess is that the power button was configured to do nothing previously, and by reinstalling Windows it has defaulted to powering down the machines. As this is now a Windows driven action there is no delay.

Have a look in the power profile settings of your machine, you probably need to just change the behaviour of your power button to be able to restore your previous configuration.

To do this, from Control Panel access Power Options.
Look in Properties then Advanced.
Under Power Buttons, select whichever option is most suited to your needs.

share|improve this answer
    
Accepted as answer for the vital clue "motherboard driven". I changed the behavior to "do nothing" and the delayed shut-down is back. Thanks a million! –  stevenvh Aug 27 '10 at 8:41
    
@steven - just spotted you said "reinstalled XP" in the question, otherwise I'd off been more precise with instructions and less vauge with the "possibly reasons it has happened". Oh well, it solved your problem anyway, but I might tweak the answer a little so it's more valid. [Edit: answer tweaked] –  DMA57361 Aug 27 '10 at 8:53
add comment

Have you installed Dell Controlpoint System Manager application installed? It should contain power management features where it's possible to set the power button behaviour.

On a "vanilla" Windows XP, try looking in Control Panel->Power Options (see this page, step 6)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.