Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

About a week ago, I noticed that a download from Firefox didn't complete. I looked at the download dialog and the download had been cancelled. I clicked the download and restarted it; it seemed to start but then I couldn't open the file.

I then copied the download link into Chrome and it worked as normal. I went to the file and double clicked it but my system told me I didn't have permissions to open the file. I right clicked and went to Properties and there was a button at the bottom called "Unblock" - I unblocked the file and it then worked as normal.

For the last week or so, I have been downloading files with this technique but it's a pain. What is going on here? I clicked around in Firefox options and found no sign of a setting that needs my attention. Has anyone else seen this?

share|improve this question

3 Answers 3

up vote 6 down vote accepted

Mozilla's article Enable downloads blocked by Security Zone Policy might have an explanation for the problem:

Downloading an executable file (e.g., an .exe or .msi file) may fail, with the Downloads window showing Canceled under the file name.

This happens because Firefox honors your Windows security settings for downloading applications and other potentially unsafe files from the Internet.

Evidently, Chrome doesn't care about the Windows security setting, but Firefox does.

The solutions proposed are:

A. Bypass Windows Security Policy check

You can add the preference, browser.download.manager.skipWinSecurityPolicyChecks and set it to true. This will bypass the Windows Security Policy.

B. Reset system Internet Security settings

You can reset your system Internet security settings in Internet Explorer.

Or for a less-destructive version of solution B, just go into Control Panel -> Internet Properties -> Security Tab, scroll down to Miscellaneous > Access data sources across domains, then change it from "Denied" to "Prompt".

share|improve this answer
    
I ended up having to reset the security settings. Firefox 3.6 cannot be fixed with the fix A, unfortunately... –  nicorellius Aug 27 '10 at 17:16

Did you get any errors from your Error Console (Ctrl + Shift + J) ?
Have you installed a new add-on / application recently?

share|improve this answer
    
No errors pertaining to this... –  nicorellius Aug 27 '10 at 17:09

For Windows XP:

Start > Run > type:

regsvr32.exe urlmon.dll

Once registered, the download problem should get solved. This should also work for Windows Vista and Windows 7.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.