Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have tried reinstalling the drivers, from the manufacturers website, and from Windows Update, but it still says no input signal in Pinnacle Studio 14. I have used this before with my computer to transfer VCRs from the same VCR player, and I remember I had some problems getting it to work then as well to begin with. I have tried it on another computer (32-bit Vista) but didn't work there either.

(I really do not get how Pinnacle can make a product that doesn't work out of the box, there are loads of other people with problems like mine after looking on the net, but Pinnacle has done nothing.)

Based on how poorly this thing works for others as well, is there any good alternatives (well they could be bad and still be better than Dazzle ;))?

share|improve this question
up vote 1 down vote accepted

Have you thought of purchasing a video capture card? Here's one on newegg

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .