Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since this morning my desktop pc (connected directly to the router) is unable to connect to the internet. My laptop is connected to the same router via a wireless access point and its internet connectivity works fine, so I assume the router is fine.

I can ping 127.0.0.1 on my desktop pc, and the lights where the network cable is plugged in shine. I have also swapped network cables. No change, so I assume the cables are fine.

The auto-assigned IP address on the desktop PC is 169.254.xxx.xxx. So I assume the pc cannot get an IP address from the router.

Also, I had a look in device manager and everything seems in order.

My router has the latest firmware.

Windows firewall is turned off. I do not have any other firewalls.

I have rebooted both router and desktop pc several times.

The latest motherboard ethernet drivers are installed.

Any ideas? Everything seems to be in perfect order, except that my desktop pc cannot get an IP address.

My environment:

  • Windows XP SP2
  • Billion ADSL Router. MAC Filtering disabled. DHCP enabled. 100 IP
    addresses available in IP range.
  • MSI K8N SLI motherboard (on-board ethernet).
share|improve this question
    
What version of windows, what service packs, what model router? –  JNK Aug 27 '10 at 18:34
    
Is the PC configured to use DHCP? Is the router configured to provide DHCP? Is the router configured for any MAC blocking? –  DMA57361 Aug 27 '10 at 18:34
1  
Routers that serve as DHCP servers generally have the ability to limit the number of leases that they'll give out. For example, I have mine set to issue only two IP addresses because that's how many devices I'll connect wirelessly. Then, if someone manages to get a connection to my network from "outside," they won't be able to get an IP address. Could this be your problem? What is the make/model of your router? –  BillP3rd Aug 27 '10 at 19:50

6 Answers 6

Can you open a command prompt and type ipconfig /release and if no error then type ipconfig /renew, what response do you get?

Check the router to make sure there are available IP addresses. If the DHCP range is small and the lease is long, the available IPs can all be assigned.

Finally, you can try manually assigning an IP you know is unused in the same subnet and trying to access the web.

share|improve this answer
    
Good tips. No, unfortunately ipconfig /release just hangs indefinitely. I have tried assigning an IP address manually, but I am still unable to connect to the internet, even with that set. –  willem Aug 28 '10 at 5:45

The following Microsoft Support articles treat the repair of TCP/IP and Winsock :

How to reset Internet Protocol (TCP/IP)

How to determine and to recover from Winsock2 corruption in Windows Server 2003, in Windows XP, and in Windows Vista

In a nutshell, as administrator you should enter in a command prompt:

Reset TCP/IP

netsh int ip reset c:\resetlog.txt

Reset Winsock

netsh winsock reset
share|improve this answer
    
Good tips. No luck though :( –  willem Aug 29 '10 at 5:06
    
@willem: Bad luck is the right word. I know of cases where Windows was reinstalled to fix TCP/IP mess-ups. Can you do system restore to a date when this worked? –  harrymc Aug 29 '10 at 7:38

Could be that windows update installed a new driver for your network card that isn't working. Check the date on the network card driver (My Computer-> Properties -> Hardware -> Device Manger) If the date is very recent date you might try rolling back the driver.

share|improve this answer
    
Nope. Good idea, but the driver is rather old. Maybe I should try and update it. –  willem Aug 28 '10 at 5:46

I have tried assigning an IP address manually, but I am still unable to connect to the internet, even with that set.

So this really is not a problem with getting an IP address. It is no network connection. So you might want to post the ip address, gateway and subnet you manually put in and the ping command and results where you tried to ping the router.

I might suspect some sort of virus or malware so I would do all the usual scans for that stuff. (ie Malwarebytes, Spybot Search & Destroy)

share|improve this answer

Windows XP network connections sometimes just get messed up. That's why Microsoft added the repair option. It's worth a shot, anyway. Right-click the problematic connection and choose Repair. Follow the prompts.

share|improve this answer

Good suggestions from all. But in the end the only thing that worked was buying a new network card.

share|improve this answer
2  
Network cards do sometimes die. Glad that you figured it out. –  Mike Chess Aug 29 '10 at 16:45
    
Were you ever able to check for an updated driver? –  Joel Coehoorn Aug 29 '10 at 18:00
    
Yup, network cards do die sometimes. I had that happen to me recently, after a thunderstorm and a 4-hour power outage hit our area. The lights on the card and on the router would flash, but the thing wouldn't get an IP from the router no matter what I tried and I ended up buying a new network card too, but not after formatting the hard drive b/c I thought it was being caused by a corrupted Windows install :-/ –  cornjuliox Aug 29 '10 at 22:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.