Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using putty from a Windows XP box to ssh onto multiple other machines. If I accidentally hold a key down too long (so it repeats more than a few times), or type too fast, putty goes into "crawl mode" so only one keystroke appears every two or three seconds. This problem doesn't happen in putty on other machines here. Is there some setting which might fix the problem? The problem isn't at the destination machine, it happens with any machine putty connects to.

share|improve this question
    
Wouldn't this question fit better in serverfault.com? –  Carlo Aug 28 '10 at 0:48
add comment

migrated from stackoverflow.com Aug 28 '10 at 2:08

This question came from our site for professional and enthusiast programmers.

3 Answers

up vote 1 down vote accepted

Deleting the whole PuTTY reg hive [HKEY_CURRENT_USER\Software\SimonTatham] seems to have cured the problem - thanks for the clue.

(There was no "known-good" machine handy to compare with, and nothing in the settings jumped out as obviously messed up; and the problem is/wasn't in Windows itself - the cmd prompt works fine.)

edit: unfortunately the problem has not been cured. It's apparent that it is NOT an issue with putty, because the same behavior occurs when using ssh from cygwin (so I'm probably wrong in thinking it is not a Windows problem.) More unfortunately I have NO clue how to begin finding a cure.

share|improve this answer
    
Be sure to mark your answer as the solution. –  qroberts Sep 29 '10 at 18:54
add comment

In my experience doing the following can slightly reduce that lags:

  • disabling bell at all (select Terminal->Bell->None)
  • re-enable Naggle's algorithm (unmark Connection->Disable Naggle's)
  • Enable data compression (mark Connection->SSH->Enable compression)

It will be great if someone explains what is going on and introduces not empirical but logical olution.

share|improve this answer
    
Enabling Nagel's Algorithm by definition will only increase lag. You want it disabled to decrease lag. –  Darth Android Sep 26 '13 at 21:16
add comment

Go into the Change Settings dialog in PuTTY. Compare the settings in Terminal, Keyboard, Bell and Features (four categories) to a known-good machine. My bet is on something in Line Discipline under Terminal or on one of the Bell settings. I'm assuming you're connecting over a network and not a serial connection.

Also start a Windows console (CMD.EXE) and see if you get that behavior there (or in something like Notepad). If so, then it's a Windows issue and not a PuTTY one.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.