Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Okay, so as the title says, I run Ubuntu 10.04. The problem is that when I boot it on battery, it doesn't come on. I see a blank screen completely. Sometimes, the Ubuntu splash is visible for a couple of seconds.

Ubuntu boots normally on AC power. But if I unplug it after I boot it up, it runs perfectly too. I can suspend it, log off, everything. I have no graphics card problem, and it doesn't seem that my problem is related to that.

I also run Windows Vista, and it runs perfectly, as it should.

If it would help, I am running an HP tx2001au laptop/tablet. Here are my specs:

CPU: AMD Turion 64x2 TL-58 (1.9 GHz) RAM: 2 GB GPU: nVidia GeForce 6150 Go

share|improve this question
In the bootloader, select the “Ubuntu” line and press e, then remove the words “quiet splash” from the line that begins with “linux” (be careful not to change anything else) and press Ctrl+x to boot. Hopefully you'll get a screen full of messages instead of a blank screen. Copy the last few lines down as precisely as possible, or if you can, take a photo and post it. – Gilles Aug 28 '10 at 7:46

I think that might be your clue @Antrikshy:

Antriksh-PC kernel: [ 1.120446] ACPI: Battery Slot [BAT0] (battery present)

My hunch is that you're seeing a problem because your battery is being improperly detected with ACPI:

ACPI Battery problems in Ubuntu

I've found a few pages which might help simply by google searching "Kernel oops acpi battery". Are you seeing an oops in the dmesg log?

Crap: Since I'm a Noob, I can't post more than one link. So they're below in the comments... I'm a believer Joel, but really? I've got a decent reputation on stackoverflow. I wish there was just one cumulative total...

share|improve this answer
Link #2: LKML Post – M. Tibbits Oct 2 '10 at 14:05
Link #3: Ubuntu Forums – M. Tibbits Oct 2 '10 at 14:06
Link #4: Google Search – M. Tibbits Oct 2 '10 at 14:06

Is it not staying on or not booting? Is the power light still on after a failed boot or does it go out? Out means battery fail. On means boot fail.

Boot "fail" may be just a VERY long disk check cycle before the system comes up (but should also be that way on AC). Have you tried booting in text mode (not the gui). Have you tried booting from a Ubuntu Live CD instead of your hard disk?

How old is the system (I'm guessing 3 or 4 years) Is your battery getting depleted? Does it boot ok with windows on battery only? Under windows what amount of battery does it claim is available after a full charge? Have you calibrated the battery meter lately under windows?

If you feel comfortable doing it, check the battery voltage with a VOM and compare that to specs for what it should be (varies by model but it should be something just slightly lower than your charger's rated output voltage).

Just like a car, the startup energy for a laptop/tablet is a bit greater than that required to keep it running. Low battery voltage might be why your battery can't start the tablet without a "boost" from the AC. It's only a 4 cell LION battery so it's a bit underpowered (battery-wise) by today's standards, especially if you've doubled the RAM already.

share|improve this answer
Yes, my battery is perfect. Windows boots on battery power and runs well for over two hours. The laptop is 2 years old. I have calibrated the battery too. Boot fails. The battery is fine. The screen remains blank and I have to shut it down directly. I am guessing that there is a software fix for this. I haven't tried booting from the CD on battery, but I believe that it won't boot also. It's not a very long disk check also. I cannot boot when on battery, and if I shut it down directly, then plug it in, and try booting, everything's fine. I can even unplug after booting, with no problems. – Antrikshy Aug 28 '10 at 7:21
Ok then, definitely it's boot fail for a non-obvious reason. See Giles comment for text mode boot. You might also look at the /var/log/messages file ( and messages.*.gz if necessary ) to see if anything unusual stands out - ie differences between an AC boot sequence messages and the battery boot messages. What it says explicitly and even Where it stopped writing messages MIGHT give a significant clue to what it's complaining about. – hotei Aug 28 '10 at 12:57
Well, I looked at the 'messages' file, and the only instances of battery were in this line: Aug 29 08:53:06 Antriksh-PC kernel: [ 1.120446] ACPI: Battery Slot [BAT0] (battery present) I'm not sure how I was booting then. Tried booting without the GUI. Text was too fast, everything was normal on battery, but still, it gave me a blank screen. I tried the same with AC power, and it was exactly the same, except that there was a new screen with some more text (different font) and it checked some more things. Some things had [OK] next to them, and battery didn't. Still, it booted correctly. – Antrikshy Aug 29 '10 at 2:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .