Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a home theater computer running Windows 7 and WMC. It is a fresh install from 5 days ago, fully patched/updated, though I have not installed WMP 12.

All my music is in a second hard drive (D:\Music).

I share D:\Music with my network which consists of two Mac OS X 10.6 laptops.

I purchased a new album on iTunes (BT's These Hopeful Machines for those curious :)).

Only three of the songs from the album (track 2, 5 and 8) appear in Windows Media Center or Windows Media Player. The songs are M4A format. All the songs in the album play just fine if I double click them in Explorer.

The folder (D:\Music) is in my Media Center/Player library for Music.

Why don't the remaining songs show up? I can play them, they just won't get added to the library. I do have other albums that have this problem, but this is the most recent and I imagine the symptom is common between them.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Well, apparently its an easy fix.

  1. Close WMP/WMC.
  2. Stop the Windows Media Player Network Sharing Service (ensures all files are open).
  3. Delete all the files in C:\Users\MyUser\AppData\Local\Microsoft\Media Player\
  4. Start the WMP Net service.

Start up WMC again and I can see the files that were previously missing.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.