Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Anyone know how to prevent picasa from capturing screenshots and saving them automatically in a folder?

This only happens when Picasa is running.

share|improve this question

3 Answers 3

Google Support Forum has: Screenshots constantly saving -- how do I stop this feature?

So, turns out Google released the screenshot feature and then bugged in some way (I expect this to be solved by now, are you using the latest Picasa edition?).

There is another reference to the forum answer by Jeffery Klassen at Lifehacker,
Stop Picasa from Filling Your Hard Disk with Unwanted Screenshots.
Since this is a relatively recent post (Apr 2010), I guess Picasa may not have have this fixed yet).

share|improve this answer
thansk nik, i am using the latest, 3.8 for pc, but its still doing it...i'll check this forum thanks for the link – Bobby S Aug 30 '10 at 2:57

I also saw this happen and the solution is very simple. This is due to a print screen key stuck on the keyboard. Just press once and see, it should stop. IF not check the print screen key. It must be stuck physically. Very simple solution:

share|improve this answer

A bit more detail for XP Pro/Vista Pro [Ed. Note: Works fine in Windows 7]

  1. Locate the screen shot folder that Picasa creates. Something like My Docs\Pictures\Picasa\Screen Captures
  2. Right Click on it > Properties > Security Tab
  3. Go to Advanced > Then in the permissions tab click Edit.
  4. Un-check the "Include inheritable permissions from this objects parent"
  5. A pop up will ask you if you want to do this and if you want to copy or remove the permissions. In this case you want to "remove" them.
  6. Apply everything and check that you no longer have access to the folder.

For XP Home/Vista Home

  1. Go to this link on information about how to get a security tab, so you can edit these settings. The easiest is to boot into safemode.
  2. Follow the directions for XP Pro.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.