Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am suddenly getting hangs on FireFox and a window comes up saying that a greasemonkey script (chrome://greasemonkey/content/preferencemanager/js.55) is not running properly and my computer may run slowly. FF completely hangs and I cannot abort or continue the script, there is no response. I have to do a hard reset.

I checked Tools>GreaseMonkey scripts and do not have any installed. Does anyone know what is happening and how I can fix this?

Thanks.

share|improve this question

4 Answers 4

up vote 2 down vote accepted

The script that you referenced isn't a greasemonkey script per se, it's a script that is part of greasemonkey. It's the thingy that runs in the background until you right click on the greasemonkey monkey in the status bar and open up the greasemonkey preferences or script manager.

share|improve this answer
    
Thanks very much. +1. I do not use greasemonkey. Some time ago I was having a problem and someone suggested GM. I added it but really don't have the knowledge to use it. Can you tell me how to remove it, or should I? Thanks again. Regards, –  Xavierjazz Sep 5 '10 at 5:04
1  
GreaseMonkey is kind of an addon that lets you install Addons, somewhat like App Store is an app that lets you install more apps. It basically runs arbitrary Javascript on sites so that you can change sites' behaviors. To remove, you just have to go into Tools->Addons and look for Greasemonkey under Extensions. Click on it and click uninstall. –  digitxp Sep 5 '10 at 13:26

Okay, you can easily uninstall Greasemonkey and install everything again. If Firefox hangs at start, follow these steps:

Go to Start -> All Programs -> Mozilla Firefox -> Mozilla Firefox (Safe Mode)

But don't click that. Hold down Shift first. When you hold the key and click it, a dialog will appear.

Uncheck the stuff you want, but remember, you want to run Foxy with all the add-ons disabled.

When you are running Firefox with disabled add-ons, uninstall Greasemonkey normally, and start the normal Firefox.

share|improve this answer
    
great answer, but -1 for the last line...we don't appreciate noise or signatures in questions or answers...Feel free to put your blog link in your 'about me' section or as your website... there is a section in the faq that also refers to this issue... Thanks! –  studiohack Sep 5 '10 at 0:35
    
quoting the Super User FAQ: "Can I use a signature or tagline? Please don't use signatures or taglines in your posts. Every post you make is already "signed" with your standard user card, which links directly back to your user page. Your user page belongs to you — fill it with interesting information about your interests, links to cool stuff you've worked on, or whatever else you like!" –  studiohack Sep 5 '10 at 1:02
    
Oh,fine. I won't do that now. –  Antrikshy Sep 5 '10 at 2:13
    
I would suggest you edit your answer to remove the spam. Regards, –  Xavierjazz Sep 15 '10 at 4:18

I did nothing. It just suddenly cleared up. I have no scripts running so I have no idea why it should have given me that message.

EDIT: I up-voted a couple of answers here as they make sense, but my basic question is unanswered. Anyone else?

share|improve this answer

Try updating/reinstalling Greasemonkey and Firefox. Preferably alternating between both a few times.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.