Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to use Windows 7 to bridge my wireless and wired connections together to get wireless on a second Windows XP computer (fresh install). The network bridge is created successfully, but when I connect the cable from the first computer with the bridged connections to the second one with just a wired connection, nothing happens. The second computer doesn't connect, and the first computer shows no sign of anything different. I tried bridging the connections of a third computer, and connecting this computer to the second computer. This worked (third computer bridged the wireless to the second computer). Thus, the problem must be with the first (Win 7) computer. However, I have no idea what the problem could be. All Internet Connection Sharing is turned off. Homegroup is disabled (it was originally enabled, I thought that might be a problem, so I disabled it). Also, I had VMWare fusion installed, and that created extra items in the "This connection uses the following items" box in the properties dialog. Thinking this might be causing issues, I uninstalled that too. Still, with everything I tried, I can't get it to work.

Any suggestions?

Edit: Another thing I noticed that might be worth mentioning: The network icon in the Win7 taskbar has a red X on it that means it's not connected, but when I click the icon, it says connected next to my wireless connection, and I am able to access the internet.

share|improve this question

7 Answers 7

problem solved for me. I'm not expert but this happen: I set up network bridge between Local area network and my Wireless connection on my laptop. The Raspberry Piis connected via LAN to my laptop.

I try many thinngs but nothing help: i can't ping for example my home router from Raspberry (10.0.0.138). Still nothing happen and I was angry. Then I look on my Raspberry Pi (via SSH) and suddenly ping works. It just take several minutes than it start working. Then I ping google.com with his IP (dirrectly) - also working :)

share|improve this answer

I have done this using the bridge method. what you do is:

  1. disable ICS and bridge the wireless and wired adaptors
  2. connect PC without wireless to bridged computer with crossover cable (it may work with regular Ethernet cable)
  3. assign wired PC with static IP obeying same subnet mask as wireless router (I have done 192.168.1.155 with netmask: 255.255.255.0) using network adaptor settings in Windows
  4. manually set wired PC to use wireless routers IP as gateway and DNS (usually 192.168.1.1)
  5. leave PC with WLAN to default automatic IP settings

All VMs must use the manual settings as well but a different IP.

ICS is easier to set up but this method enables network between both computers even when the wireless network is not connected and also behaves as regular ICS. Hope this helps and good luck with your network.

P.S.: This method also works for an Xbox 360 and you will always get the red x icon as long as the wired PC is off.

share|improve this answer

I have been an IT admin for over 10 years and I cannot tell you what you should be doing because I do not exactly know the particulars of your network.

What I can tell you is it sounds as though you do not have promiscuous mode enabled on both adapters of the host machine.

To verify this, open a command prompt and type netsh bridge show adapter. Any adapters listed that does not have "enabled" under "ForceCompatibilityMode" will need the value changed.

To do this, type netsh bridge set adapter X forcecompatmode=enable (where X is the value of the adapter in a state other than "enabled"). Once you have done this for all adapters in the list, run the first command again to verify the settings.

You should be good to go, although you may need to disable and re enable the adapters on any of the other workstations. As for individuals making assumptions that they know better than what an end user at a remote site needs, try helping out or at least ask the correct questions before you draw a conclusion of their needs..

share|improve this answer

You need to have on your wireless adapter's sharing turned on and on the wired adapter's sharing off.

Then just plug a cable between them both and the "host" laptop should assign the one without wireless capabilities a random IP on a DCHP server the "host" created.

For example:

  • If the "host" laptop created the network 192.168.137.X
  • It will assign itself as 192.168.137.1
  • then randomly assign any of the other PC's connecting to the "host" at 192.168.137.24

You can do this with a hub/switch or just a direct connection through Ethernet.

share|improve this answer

I'm thinking it's actually just the hardware that's not capable of bridging or sharing - not software related at all. Anyway, I have found other ways of doing what I wanted.

share|improve this answer

I had the same problem bridging connections. In order to bridge connections in Windows 7 you need to select the two connections and then right click to bridge. If you are just right clicking on one, you will get an error message about Ineterconnection sharing and needing 2 or more connections. It sounds like he wants bridging. The difference between internet connection sharing and bridging is that with ICS one of the network adapters will be NAT/DHCP server for the computers on the local network. So if you are already using a wireless router from your dsl/cable modem you will probably just want to bridge the connections.

share|improve this answer

Bridging is the wrong answer here. What you would need to do is to set up internet connection sharing on the desktop. Here is a good guide on how to do it.

http://windows.microsoft.com/en-US/windows-vista/Using-ICS-Internet-Connection-Sharing

share|improve this answer
    
If I do that, then which network do I want to turn sharing on for? The wireless or the wired? And do I need a wired hub, like they show in the diagram on that site? And do I need to set up sharing on the second computer as well? If so, how? I don't see an option to do so. –  D. Strout Aug 30 '10 at 0:24
    
OK, I tried it on both connections on the first computer (wired + wireless), I tried checking all the boxes in the Settings box, and still nothing happens on the second computer. I really have no idea how internet connection sharing is supposed to work. –  D. Strout Aug 30 '10 at 0:31
    
You should be setting things up to share the wireless connection to the wired connection. You may also need to manually assign IP addresses. I suggest setting the host's wired card to 172.18.18.1 and the client's to 172.18.18.2, both with a hostmask of 255.255.255.0 –  Ryan Gooler Aug 30 '10 at 6:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.