Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I went to help out with an HP PC this morning which had been running slow, but otherwise working fine. A trial of Norton Internet Security 2010 was installed on the PC, and I went to my usual routine of uninstalling it in order to put Microsoft Security Essentials on instead.

After the restart, I found that the PC could no longer browse the web. Internet Explorer would respond "Website contacted, waiting for reply" in the status bar. I attempted to ping out to various computers. I could ping another computer on the local network, and I could get a ping back from google (but no web page.) I could still browse the internet just fine from the other PCs.

I began my investigation, and tried out the more standard methods for resolving the problem. I tried:

  • Running the Norton Removal Tool
  • netsh int ip reset reset.log
  • netsh winsoc reset catalog
  • repeating the above a few times in various orders
  • Verified that there is no proxy set in the Internet Settings in the control panel
  • Tromped through the registry, removing any reference to "Norton Internet Security" or Norton at all.

Other interesting symptoms:

  • the broken machine can ping working machines, but not vice versa.

I tried resetting the Internet Explorer settings to their defaults. However, this was the strange part: the reset hung at the "Applying default settings" arrow, and never progresses.

Because this was an HP machine, there seems to be no windows 7 CD. However, there is the recovery partition. I'm wary of using it, because I haven't used one before and don't know how much or how little it will do to this PC.

Any thoughts?

Update 2

Answers to questions:

Are you connecting wirelessly, or connecting directly with an ethernet cable?

In this case, it's actually a desktop. It's connected via cable.

What are you getting for an IP address and DNS server?

The IP address is one in the right range assigned by the router that we have between the modem and our network. a 192.168 address. The DNS server information matches what we have for the working PC.

Do any alternate browsers work normally? This will determine if there's a problem with just IE or a problem with connectivity.

Chrome fails to connect to the internet too, with the same kind of error. Other applications such as windows update and other applications that try to access the internet also fail to connect.

Update 3

Check the Network Adapter

Checked. It says it's enabled.

Run the Windows 7 Troubleshooter

Ran. It tried to connect to the internet to get a troubleshooting pack, (failed?), then couldn't detect what the problem was.

Pinging Google, connecting directly to the IP

Google would respond to a ping, but bing wont. Yahoo replies with a ping, m-w.com does, most places seem to respond to a ping.

Update 4

Thanks everyone for their suggestions. Turns out this wasn't Norton's fault...this time; it was coincidence. See my answer below for the final solution!

share|improve this question

6 Answers 6

Run the Norton Removal Tool. After running it and having deleted all Norton programs, reboot your computer. Run the tool a second time and reboot again.

share|improve this answer
    
I did :( Three times :( –  Robert P Aug 30 '10 at 4:39
    
@pepkaro Good itś finally solved! –  BloodPhilia Aug 30 '10 at 9:19
up vote 2 down vote accepted

Finally figured it out. We wired up another PC to the router (A linksys Wireless-G router) originally, the second PC was connected via wireless. Turns out the router had decided to stop forwarding HTTP packets via the physical ports, but NOT the wireless. After a reboot of router, the internet returned!

Moral of the Story: If everything you tried didn't work, it might be something completely different. :)

share|improve this answer
1  
Congrats on becoming Norton free !! –  dimitri.p Aug 30 '10 at 5:16
    
If all else fails, think outside the box! –  Moab Aug 30 '10 at 15:32
    
@dimitri: haha, well, it's my parents, not me (MSE for me all the way), but basically yeah. :) –  Robert P Sep 4 '10 at 15:21

The recovery procedure will wipe the laptop and restore it to how it was when it was shipped from the factory. All your data will be lost.

You probably shouldn't have messed around in the registry, as it might have done more harm than good. The only time I muck around in the registry is for something very specific or when I clean a computer's registry using ccleaner. Go ahead and try that tool.

Are you connecting wirelessly, or connecting directly with an ethernet cable?

What are you getting for an IP address and DNS server?

Do any alternate browsers work normally? This will determine if there's a problem with just IE or a problem with connectivity.

share|improve this answer

Since you can ping the IP of google, can you connect to, say, http://74.125.19.104? Or, the https version?

If this works, then you have a DNS issue, which can be solved by setting your DNS servers to manually go to 8.8.8.8 and 8.8.8.4

share|improve this answer
    
Unfortunately, direct connect to the IP does not help. I still get the "Waiting for ..." message. :( –  Robert P Aug 29 '10 at 22:08

Windows 7 comes with a very good troubleshooter, just click the network icon in the notification tray and it'll check for any problems with connectivity.

Also the easiest and never thought of solution is that there may have been a bug in the Norton uninstallation and it could've disabled your adapter.

Open the network sharing center by right clicking the network icon and going to open network and sharing center.

Then go to Change Adapter settings in the left sidebar, then locate your adapter, and check if it is enabled.

share|improve this answer
    
See responses above. The adapter is enabled, and and the troubleshooter couldn't find anything wrong. :( –  Robert P Aug 29 '10 at 22:24

Try resetting IE, even if you use another browser.

I have seen malware do the same thing after you remove it, it makes sense, I consider Norton Products to be malware :-)

To reset Internet Explorer settings manually

Close any Internet Explorer or Windows Explorer windows that are currently open.

Open Internet Explorer by clicking the Start button , and then clicking Internet Explorer.

Click the Tools button, and then click Internet Options.

Click the Advanced tab, and then click Reset.

Select the Delete personal settings check box if you would like to remove browsing history, search providers, Accelerators, home pages, and InPrivate Filtering data.

In the Reset Internet Explorer Settings dialog box, click Reset.

When Internet Explorer finishes applying default settings, click Close, and then click OK.

Close Internet Explorer.

share|improve this answer
    
I would love to finish attempting this. However, as I mentioned in the post, it hangs indefinately at the "Applying default settings" bullet point. –  Robert P Aug 29 '10 at 22:09
    
Any idea of how long it should take? Seconds? Minutes? Hours? We're talking about a reasonably new PC here. –  Robert P Aug 29 '10 at 22:38
    
It seems to have finished this time. No dice :( –  Robert P Aug 29 '10 at 22:56
    
Run a SFC support.microsoft.com/kb/929833, reboot when done. HP recovery is a factory restore process that will wipe everything from the PC and restore to an as shipped condition. Make a Windows System Repair CD, go to All Programs>Maintenance> Backup and Restore, click the "create a system repair disc" on the left side. –  Moab Aug 30 '10 at 1:23
    
If you have not done so yet, make a set of HP recovery DVD's,...h10025.www1.hp.com/ewfrf/wc/… –  Moab Aug 30 '10 at 1:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.