Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Solved! Hooray!

This problem has been solved by the author...

In general, port forwarding works for me.

Currently I want to add a port, 80 to 8080, host to client, but i just cannot use port 80 on my host.

e.g.

Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/ssh/GuestPort, Value: 22
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/ssh/HostPort, Value: 2222  
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/ssh/Protocol, Value: TCP

works, i can login on www.mydomain.tld:2222 via ssh. bam!

Trying 80 to 8080

Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/nginx/GuestPort, Value: 8080
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/nginx/HostPort, Value: 80
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/nginx/Protocol, Value: TCP

does not work, netstat also does not show me any listening on port 80 on host-linux.

I dont know how to debug that, tailing the log gives me:

00:00:00.373 Changing the VM state from 'CREATING' to 'CREATED'.
00:00:00.374 Changing the VM state from 'CREATED' to 'POWERING_ON'.
00:00:00.374 NAT: set redirect TCP host port 2222 => guest port 22 @ 10.0.2.15
00:00:00.374 NAT: set redirect TCP host port 80 => guest port 8080 @ 10.0.2.15
00:00:00.374 NAT: failed to redirect TCP 80 => 8080
00:00:00.375 Changing the VM state from 'POWERING_ON' to 'RUNNING'.
share|improve this question
    
ah my bad - please feel free to slap me - it wassnt run as root, so binding ports lt 1024 just fails.. – dhanke Aug 29 '10 at 21:35

You must log in to answer this question.

Browse other questions tagged .