Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i haved configured my conky, and i want to run it on startup, i did found some tuts on internet, i haved put my conky in the startup, but in the screen, it just show just a second and gone..so how will i resolve that?

share|improve this question
up vote 2 down vote accepted

Simple... Create .startconky at ~/

Insert the code code shown below

#! /bin/sh -e
sleep 15
conky
exit 0

Then create a Startup Application. Under System->Preferences

And at command line field.

/bin/sh /home/username/.startconky

Thats all.

share|improve this answer

Well, first we'd need to get to the bottom of the problem. Does running conky from a terminal work? We can tell for sure that conky itself is not the problem. If you go into Startup Applications and change the Conky entry to sleep 35 && conky does it run? Yes? Problem solved.

share|improve this answer

Adding conky to my startup apps also didn't work very well for me. Instead, I added a shell script which sleeps for about 30 seconds, and then launches conky against my customized configuration scripts. I added that script to my startup applications.

#/bin/bash
sleep 30
conky -q -c ~/conkys/conkyrc_wireless.sh &
conky -q -c ~/conkys/conkyrc_weather.sh &
...
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .