Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a real problem that I've been troubleshooting for a friend that has really left me clueless. My friend recently had a laptop die on him and instead of buying another laptop he had me build him a desktop. Everything was working great when I set it up at my house but once he took it home he began having trouble getting a good connection over his wireless card that I had installed for him (it worked great at my house.)

I've spent hours trying all of the obvious stuff, including:

  • Installing/trying a new wireless adapter
  • Installing/trying a new router
  • Purchasing a wireless range extender
  • Messing around with all the router settings (channels, power output, etc)

I would say he's just got it in a bad spot in his house but here's the thing: no other computer has a problem connecting to the internet at all from the exact same spot his desktop sits. All of these routers/adapters work fine with other computers but he gets a low signal strength and shoddy internet once we put it in his computer at his house (like I said it worked fine at mine)

Does anyone have any idea what could be causing this problem?

EDIT - Extra info:

Router is running on mixed mode I believe (so b/g/n I think) and I'm not sure of the exact speed he gets, but it is intermittent and pretty crappy...Google would take around 5 seconds to load sometimes and >500ms ping in WoW.

share|improve this question
5  
wow, that is some problem...+1 –  studiohack Aug 30 '10 at 1:39
    
One option is to call it a quirk of the computer natural selection and sell and buy a new motherboard. –  digitxp Aug 30 '10 at 2:31
1  
Some more specific background info might help. Model of computer. What OS. Make/model of wifi card, and type of antenna if detached. Distance from wifi access point to the "dead zone" location. Which wifi type you're using "b/g/n". What speed is the system actually getting when it hooks up (in bits/sec). And you're right, it sounds really weird. –  hotei Aug 30 '10 at 3:04
    
I added the extra info. Hope it helps! –  alexbaumhoer Aug 30 '10 at 3:25
    
If you try to boot this problematic computer from Ubuntu live-cd, is the connection slow there, too? –  Janne Pikkarainen Aug 30 '10 at 11:25

6 Answers 6

up vote 5 down vote accepted

I think something in your friend's environment is causing the problem. Does he have a cordless phone? If so, unplug the base unit as a test and see if that makes any difference. I had to replace my cordless phone when I started using wireless. Does your friend share his house with other tenants who might have similar wireless devices?

share|improve this answer
    
I imagine there probably are some cordless phones in his house...I linked him this article so he should be able to try unplugging the phones to test. Is it weird though that radio interference would only affect one computer in the house? –  alexbaumhoer Aug 30 '10 at 19:51
    
@Baumage: Not really. Specific devices have varying degrees of sensitivity, depending on many factors. Tuning and troubleshooting wireless networks is a bit of a black art. There is advanced (and expensive) software out there for identifying and resolving issues (like Wi-Spy as mentioned by Spiff). I wish I could afford it. :( The rest of us are stuck with basic troubleshooting techniques, such as disabling possible interference sources. –  boot13 Aug 30 '10 at 20:28

Is he by any chance using a different display at his house than the one you tested with at your house?

Graphics cards have to run lots of different oscillators (crystals, clocks) at different speeds to accommodate different resolutions and refresh rates. It's not uncommon for these clock rates to hit, say, 2.4GHz, or a harmonic of 2.4GHz. This means that a graphics card that wasn't emitting much 2.4GHz noise when connected to one display, could be destroying the 2.4GHz or 5GHz band when connected to a different display.

If you've been using an internal 802.11 card, switch to a USB dongle at the end of a USB extender cable (or plugged into a hub) that you can position well away from the enclosure and display. Also make sure you've replaced all the PCIe fence slot covers and the case/door and any other pieces of RF shielding on the enclosure.

Someone suggested inSSIDer, but running a software-only tool on an 802.11 card won't show you non-802.11 interference in the band. For that you need real spectrum analysis hardware, such as a Wi-Spy.

Heh, one last late thought: Did you go to his house to look at his problem? Because if not, it would be really funny if it was something stupid like he forgot to reattach the antennas when he brought the box home, and you assumed that was too obvious to ask about...

share|improve this answer
    
I thought OP said it worked ok at his house. IF CPU RFI was the cause that wouldn't be the case (assuming fixed rate clock crystal). Plus I hardly think an OEM would get past FCC tests if their GPU was putting out that much RFI. Not impossible, but seems unlikely. –  hotei Aug 30 '10 at 4:12
    
@hotei, did you miss all the part where I asked if he used a different display. I've seen this make the difference between Wi-Fi working and not working. As for FCC tests, note that a graphics card isn't "finished goods". It's an internal component meant to go inside a shielded box (your computer's enclosure), so it doesn't go through the same testing process as finished goods (like a complete premade system from HP or Dell or someone) would have to go through. Unfortunately, that means it can interfere like crazy with other components inside the shielding, like your wireless card. –  Spiff Aug 30 '10 at 4:25
    
Good point. Sloppy hardware engineering is rarer these days but it still happens. –  hotei Aug 30 '10 at 4:45
    
The display is the same as the one tested at my house. That is interesting about the graphics card interfering with wireless signals though...will keep that in mind when troubleshooting these problems from now on. –  alexbaumhoer Aug 30 '10 at 19:53
    
Is he using the same display settings as well? Because if he prefers a different resolution or refresh rate, that could make the same kind of difference. –  Spiff Aug 30 '10 at 21:22

Have you tried moving the PC closer to the wireless router to see if there is interference with that one area (Perhaps a black hole of wifi death)? I know that sometimes, especially since most desktop pc's are placed in areas surrounded by walls, and other metal objects that interference can be happening.

A good tool for diagnosing channel, strength and interference from other routers is inSSIDer Perhaps in that one area there is enough interference from other networks. Hope this gives you a couple of ideas.

share|improve this answer
    
I should have mentioned this in my original post...he did inform me that when he moved the computer downstairs he was able to get a good wireless signal. This would lead me to believe that it is the area of the house he is in...but why do no other wireless devices have any problem connecting from the exact spot his desktop sits? –  alexbaumhoer Aug 30 '10 at 19:55
    
Again its the actual placement of the antenna. It could be just the way that the antenna is picking up the waves from the router. –  KronoS Aug 30 '10 at 20:57
    
You could test KronoS's idea by turning the computer 90 degrees and seeing if that changes the network performance. –  CarlF Sep 10 '10 at 12:36

Still would like to know distance and speed obtained at that distance. Win7 wifi properties will tell you max speed of connection with given signal strength.

Anyway - some speculation... Building a desktop with wifi can be tricky because the metal box of the desktop will block the wifi signal in some directions. Successful (ie. HP-OEM) wifi usually uses a loop antenna at the top of the desktop case mounted inside a plastic "top-hat". The plastic "top-hat" allows wifi in and out without degradation. Laptops don't generally have this problem since most (non-apple) are cased with plastic. Since your wifi is at the back of the desktop the orientation of the desktop to the access point will be critically important. Distance is also important if the signal is being partially or significantly blocked by the case. Perhaps it succeeded at your house because the orientation / distance aspects were more favourable than at your friends.

The USB plugs are known to be especially vulnerable to blockage by the metal case. Linksys used to include a USB extender cable with theirs just for that purpose. I have one of them next to my keyboard that I use regularly to attach thumb drives to ports on the back of my desktop. The twin antenna PCI card should be less vulnerable, but I still suspect that blockage is the culprit.

share|improve this answer
    
I'm sorry, the computer is not with me so I can't quote you an exact speed. I can say the distance is probably less than 25 feet in straight line from the router. His USB adapter (which gains a little better signal than the twin antennas adapter) does have an "extension cord." I tried moving it around in all directions but could not get any better signal regardless of location/distance from computer/monitor. –  alexbaumhoer Aug 30 '10 at 19:57

Please look if MAC filtering is enabled on the router. If MAC filtering is enabled on the router, it means that, the MAC address of all the other computers connecting to the network will be given access to connect to internet. And if any new computer tries to connect it will not allow.Because the router does not recognize the MAC address of this new computer. Disable the MAC filtering in the router page or add the MAC address of this new computer into the router page and issue should be solved.

share|improve this answer
    
This can't be the problem, because the homebuilt PC does connect, just not at full speed. –  CarlF Sep 10 '10 at 12:37

If your open to all suggestions try an outlet test on the wall outlet for proper wiring, you never know

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.