Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So, I installed Ubuntu (Using Gnome) with keyboard layout US International with Dead Keys enabled. Now I've set this to US International with Alt-Gr Dead Keys enabled. I added the latter and deleted the first. I then clicked "Apply to entire system" and closed the keyboard manager.

Now whenever I reboot, the old keyboard lay-out is re-added to the list and set to the default keyboard layout. The keyboard with US International with Alt-Gr Dead Keys enabled is still in that list so it doesn't completely revert to the installation settings, making me conclude that it must have saved the settings...

How can I make this keyboard ghost go to the eternal /dev/null/ plane so that it will never rise from the grave again? (How to get rid of the thing...)

share|improve this question

2 Answers 2

I recently had a similar problem with my Ubuntu installation. I installed Ubuntu with a Dvorak keyboard layout and could not switch to a standard layout.

I was able to fix my problem by removing every layout but the layout I wanted to use under keyboard preferences > layout.

share|improve this answer
up vote 1 down vote accepted

From http://ubuntu.stackexchange.com/questions/3355/keyboard-layout-on-ubuntu-wont-go-away by Richard Holloway there:

Apparently setting the keyboard layout you wish to use when logging in solves this problem.

When logging in, as you are about to enter your password in GDM, there is a discreet menu option on the toolbar at the bottom.

Changing the setting here will cause Ubuntu to use the correct keyboard setting not just for that session but for subsequent log ins.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.