Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I gunzipped and tarred ace_tao5.6.3.tar.gz. After creating the "ACE_wrappers" directory I successfuly ran configure. When I tried to make, I got an "Open SSL" missing dependency.

After installing the ubuntu open-ssl package using apt-get, I tried to make again, but it failed with errors such as:

../../../../ASNMP/examples/get/get.cpp: In constructor ‘getapp::getapp(int, char**)’:
../../../../ASNMP/examples/get/get.cpp:92: error: ‘cout’ was not declared in this scope 
../../../../ASNMP/examples/get/get.cpp:107: error: ‘cout’ was not declared in this scope 
../../../../ASNMP/examples/get/get.cpp: In static member function ‘static void getapp::usage()’: 
../../../../ASNMP/examples/get/get.cpp:142: error: ‘cout’ was not declared in this scope 
../../../../ASNMP/examples/get/get.cpp:147: error: ‘endl’ was not declared in this scope 
../../../../ASNMP/examples/get/get.cpp: In member function ‘int getapp::run()’: 
../../../../ASNMP/examples/get/get.cpp:156: error: ‘cout’ was not declared in this scope 
../../../../ASNMP/examples/get/get.cpp:167: error: ‘cout’ was not declared in this scope 
../../../../ASNMP/examples/get/get.cpp:181: error: ‘endl’ was not declared in this scope

I don't know how to proceed. Please advise me. Thanks

share|improve this question

1 Answer 1

up vote 0 down vote accepted

After upgrading to ace_tao5.6.5.tar.gz, I configured and built ace sucessfully.

As I was trying to build tao, I realized that I already had a .deb for ace+tao! A .deb is a debian library that Ubuntu's operating system uses. I just ran dpkg on the .deb, and had ace+tao installed!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.